Global Variable

errSecCertificateExpired

An expired certificate was detected.

Declaration

var errSecCertificateExpired: OSStatus { get }

See Also

Certificate Result Codes

var errSecUnknownCriticalExtensionFlag: OSStatus

There is an unknown critical extension flag.

var errSecCertificateCannotOperate: OSStatus

The certificate cannot operate.

var errSecCertificateNotValidYet: OSStatus

The certificate is not yet valid.

var errSecCertificateRevoked: OSStatus

The certificate was revoked.

var errSecCertificateSuspended: OSStatus

The certificate was suspended.

var errSecInvalidCertAuthority: OSStatus

The certificate authority is not valid.

var errSecInvalidCertificateGroup: OSStatus

An invalid certificate group was detected.

var errSecInvalidCertificateRef: OSStatus

An invalid certificate reference was detected.

var errSecCertificateNameNotAllowed: OSStatus

The requested name isn’t allowed for this certificate.

var errSecCertificatePolicyNotAllowed: OSStatus

The requested policy isn’t allowed for this certificate.

var errSecCertificateValidityPeriodTooLong: OSStatus

The validity period in the certificate exceeds the maximum allowed period.