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The typical way to add HTML elements to a page in WebObjects Builder is to drag the element from the Static 
Elements palette. The Static Elements palette contains icons for the most common HTML tags that current browsers 
support. If you want to add an HTML element that isn't on the palette, create a custom tag.

You also can type text directly in the component window. Typing text directly in the component window creates text 
with <BR> elements at each carriage return. 

Common HTML Elements and How to Create Them

If you want to find out how to create a specific HTML element using WebObjects Builder, see the topic listed in the 
following table:

To create this element: With this HTML tag: See this topic:

Address <ADDRESS> Using the Static Elements Palette

Block quote <BLOCKQUOTE> Using the Static Elements Palette

Definition lists <DL>, <DD>, <DT> Using the Custom Tag

Form elements <FORM>, <INPUT>, <SELECT> Creating Form-Based Dynamic Elements

Frames <FRAME> Using the Custom Tag

Header elements Any element that belongs inside 
<HEAD>...</HEAD>

Setting Page Attributes

Headings <H1> through <H6> Using the Static Elements Palette

Horizontal rule <HR> Using the Static Elements Palette

Hypertext link <A> Creating Hyperlinks

Image <IMG> Creating Images

Line break <BR> Type a carriage return

Ordered lists <OL>, <LI> Using the Static Elements Palette

Paragraph <P> Using the Static Elements Palette

Preformatted text <PRE> Using the Static Elements Palette

Table <TABLE> Creating Tables

Typographic elements <STRONG>, <EM>, <FONT> Setting Font Attributes

Unordered lists <UL>, <LI> Using the Static Elements Palette

WebObjects <WEBOBJECT> Creating Abstract Elements
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Using the Static Elements Palette

Each icon on the Static Elements palette represents a group of HTML tags. For example, the Heading icon 
represents all HTML headings, <H1> through <H6>. The Paragraph icon represents all paragraph styles: 
Preformatted text, Block quotes, Addresses, and plain paragraphs. “HTML Elements on the Static Elements 
Palette” lists the HTML tags you can create using the palette. If there is no palette icon for the HTML tag you want, 
create a custom tag.

1. Place the cursor where you want the element to appear on the page.

2. If the palette window isn’t displayed, click the palette button to display it. 

3. Drag the element from the palette window onto the page.

4. Select the element. 

5. If the inspector window isn’t displayed, click the inspector window to display it. 

6. In the inspector, select the element type you want. 

Formatting Tips

Web pages are text flows, and WebObjects Builder edits Web pages as text flows. 
Because the page is a text flow, you can’t just drag an element to any coordinates in 
the window. Instead you must place the cursor before you add the element. 

Here are some tips that might come in handy when you’re trying to get the page to 
look the way you want it to:

• Create space above an element by placing the cursor above the element and 
pressing Enter to insert some blank lines. 

• To select an element, you must select both the text inside the element and the 
element itself. That is, you must see the dotted border around the element, and 
all of the text inside the dotted border must be visible.

• To center an element on the page, select the element, and click the centering 
icon.

• You can delete just the element tags but leave the text intact. See “Changing or 
Deleting Tags.”

• If you make a mistake, choose Edit->Undo. Executing Undo twice undoes the 
last two commands. To undo an undo, choose Redo.
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See “Formatting Tips” if you’re having trouble editing the page. 

If the element you added has an HTML-defined attribute that you want to set, see if it can be set in that element’s 
inspector. If not, you can set it manually by clicking the HTML Expert check box in the inspector. When you click 
the check box, the inspector window gives you a representation of this element in HTML. You can add, delete, or 
change attributes. Click the HTML Expert check box again to turn off HTML Expert mode. Note: WebObjects 
Builder does no checking that the attribute you entered is valid HTML or has a valid value.

HTML Elements on the Static Elements Palette

You can create any of these HTML tags using icons on the Static Elements palette:

• <A> (See “Creating Hyperlinks”)

• <ADDRESS>

• <BLOCKQUOTE>
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• <H1> through <H6>

• <HR>

• <OL>

• <P>

• <PRE>

• <TABLE> (See “Creating Tables”)

• <UL>

Palettes

A palette is a collection of static or dynamic HTML elements. You use the palette 
to add elements to a page. 

To open the palette window, choose Tools->Palettes->Palettes or click the palette 
button on the component window.

The palette window holds all currently loaded palettes. You select a particular 
palette by clicking its icon at the top of the palette window.
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• Static Elements palette displays static HTML elements. 

• Form Elements palette displays form-based dynamic elements. 

• Abstract Elements palette displays dynamic elements that have no direct 
HTML equivalent. These elements are often not “visible” when you are con-
structing the page in the way that the form-based elements are visible. They 
are replaced with text and graphics by your application at run time. 

The three palettes listed above are standard palettes and are always displayed. You 
can create your own palettes and you can load palettes created by someone else. 
See “Creating a Palette” and “Loading and Unloading Palettes” for more 
information.

Inspectors

The inspector window displays the bindings, attributes, and other settings for the 
currently selected element and other elements in the HTML hierarchy. 

To open the inspector window, choose Tools->Inspector or click the inspector button on 
the component window.
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Using the Custom Tag

If there is no palette icon for the HTML marker you want, create a custom marker. “HTML Elements Not on the 
Static Elements Palette” lists some elements you create with the custom tag.

Each element on an HTML page occupies a place in the hierarchy. That is, a button is 
contained by a form, which is contained by the body, which is contained by the page. 
The page is the highest level in the hierarchy. 

When you inspect an element, the icon path in the inspector shows an icon for each 
element in the hierarchy. Dynamic elements display two icons in the icon path. One 
represents the element’s HTML attributes and one represents the element’s bindings. 
For example, suppose you have WORepetition that is contained in a WOConditional (so 
that the WORepetition displays its contents only if a certain condition is true.) When 
you inspect the WORepetition, you’ll see five icons in the inspector’s icon path: the 
page inspector, the WOConditional HTML inspector, the WOConditional bindings 
inspector, the WORepetition HTML inspector, and the WORepetition bindings 
inspector. 

  

The HTML Expert check box applies to the HTML attributes inspector only (not to 
the bindings inspector). This check box turns on HTML Expert mode. When in 
HTML Expert mode, the inspector window gives you a representation of the selected 
element in HTML. You can add, delete, or change attributes. Click the HTML Expert 
check box again to turn off HTML Expert mode. Note: WebObjects Builder does no 
checking that the attribute you entered is valid HTML or has a valid value.
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1. Place the cursor where you want the element.

2. In the Static Elements palette, click the custom tag icon and drag it onto the page. 

3. In the inspector window, enter the tag’s name. 

4. Return to the component window and enter the text of the element. 
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A custom tag is an element whose tag name is editable. The default name for custom tags is mymarker . After placing 
the tag, you change the default to the name of the HTML element you want to create, such as DL. You can also specify 
whether your custom tag requires an end tag, such as /DL . 

Tip: To save the custom tags so you can use it again, create a custom palette.

HTML Elements Not on the Static Elements Palette

• <FRAME>

• <DD>

• <DL>

• <DT>
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Creating Hyperlinks

There are two types of hyperlinks that you might use in a WebObjects application. The first is a static hyperlink, 
whose contents and destination file never change. The second is a dynamic hyperlink (WOHyperlink). To create a 
dynamic hyperlink see “Creating Dynamic Hyperlinks.” 

To create a static hyperlink:

1. Click the link button. 

2. Type the text that the hyperlink should contain. As you type, the text is underlined. 

3. Click the link button again. 

4. While the hyperlink element is selected, set its destination in the inspector window. 

 

You can also create this type of link by dragging the hyperlink from the Static Elements palette (See “Using the Static 
Elements Palette.”) or by selecting text and then clicking the link button.

Creating Tables

Create a table just like you would any other type of static HTML element: Place the cursor where the table should 
appear, and drag the table from the Static Elements palette. (See “Using the Static Elements Palette”.)
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• To edit the table, click inside the table. You will see resize borders and arrows pointing down and to the right. 

• To resize the table, drag a resize border. You can drag a column edge to resize one column. 

• Add columns by dragging the right arrow. 

• Add rows by dragging the down arrow.

• To select a row or column in the table, drag the mouse across it.

• To delete a row or column, select it and press the Delete key. 

• To merge cells, select the cells and choose Format->Table->Merge Cells.

• Set the HTML attributes for a table (for example the size of its border, cell padding, and alignment) in the inspec-
tor window. 

• To add another HTML element inside of a cell, make sure you have the text inside the cell selected rather than 
the cell itself, then drag the element from the palette.

• You can also add an element outside of a table cell (for example, you can add a WORepetition around a table row) 
by selecting the row and dragging the element onto it.

Tip: To set bindings for an element that surrounds a table row, use the inspector interface. Click inside the row, then 
select the element from the icon path in the inspector. See “Selecting Elements” and “Binding Elements Using 
the Inspector” for more information.
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Creating Images

1. In the component window, place the cursor where you want the image to appear.

2. Locate the image in the file system. 

3. Drag the image onto the page.

  

WebObjects Builder supports .jpeg, .gif, .tiff, .eps, and .bmp images.

By default, WebObjects Builder copies the image into the component directory unless you are dragging from a shared 
directory. See “Sharing Resources.”

To set an image for the page background, use the page inspector. See “Setting Page Attributes.”

Setting Font Attributes

Use the toolbar on the main window to set font attributes:



14

HTML Editing in WebObjects Builder Setting Colors

 See “Creating Hyperlinks” for information on the link button shown above.

See “Setting Colors” for information on how to use the Colors panel that opens when you click the color well.

Setting Colors

WebObjects Builder supports Netscape and Internet Explorer named colors. You can use the Colors panel to choose a 
color from one of these sets, or you can create your own color using the color wheel. 

1. Click the border of a color well. 

2. Click the Pantone button.

3. Choose a color set from the pop-up list.

  

Setting Page Attributes

1. Select any element in the page. 
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2. In the inspector window, click the leftmost icon. (Click the inspector button to display the inspector window.) 

 

“Setting Colors” describes how to use the Colors panel that opens when you click a color well border.

You use the table on the page inspector only if you’re creating a component that can be reused. See “Creating 
Reusable Components” for more information.

Selecting Elements

Before you can copy, delete, or inspect an element, you need to select it. To select an element:

1. Click the element once so that a dotted rectangle appears around it. 

2. Drag to select all of the text inside the element. 

To select multiple elements, continue dragging until all elements are selected. (Shift-clicking does not work.)
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An HTML element isn’t just the text you see on the page; it’s also the tag that specifies how to format the component. 
For example, if you were writing HTML without using an HTML editor and you wanted to create a heading, you’d 
type:

<H1>Large title</H1>

To do this in WebObjects Builder, you drag the heading element from the Static Elements palette, select the text, and 
type Large title . You see a dotted line around the text you’ve typed. That dotted line represents where the <H1> 
and </H1>  format specifiers are. 

If you want to delete or to copy this heading, you must make sure the dotted rectangle appears and all text within the 
rectangle is selected. 

Note: Some elements are difficult to select. For example, it’s often impossible to select a WORepetition that surrounds 
a table row inside of a table. In such cases, you can always find the element’s attributes in the inspector. Click inside 
the table row and then select the repetition’s icon in the inspector’s icon path. This way, you can set or inspector the 
element’s bindings and other attributes, but you won’t be able to delete or copy it. 
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Changing or Deleting Tags

You can change or delete an element’s tags, leaving the text intact. To do this: 

1. Select the element.

2. From the Format menu, choose the command that deletes elements of this type.

3. Choose a command from the Format menu to add different element tags. 

 


