Last Revision:
Version 1.6, 2011-11-10
Updating the AppleJavaExtensions.jar to correspond to Java for Mac OS X 10.7 Update 1 and 10.6 Update 6.
(Full Revision History)
Build Requirements:
Any Java SE 5.0 or higher compiler.
Runtime Requirements:

This is a pluggable jar of stub classes representing the new Apple eAWT and eIO APIs for Java on Mac OS X. The purpose of these stubs is to allow for compilation of eAWT- or eIO-referencing code on platforms other than Mac OS X. The jar file is enclosed in a zip archive for easy expansion on other platforms. These stubs are not intended for the runtime classpath on non-Mac platforms. Please see the OSXAdapter sample for how to write cross-platform code that uses eAWT.