Documentation Archive

Developer

Xcode Overview

Using Multiple Workspace Windows

Create multiple workspace windows by choosing File > New > Window. Each window can be customized independently of the others.

For example, Figure 8-1 shows the storyboard editor in one window and running the view debugger in another.

Figure 8-1Multiple workspace windows image: ../Art/XC_O_workspace_multiple_2x.png

Using Tabs

Use tabs to implement multiple, workflow-specific layouts of the workspace window. Add tabs to a workspace window by choosing File > New > Tab, or by clicking the Add (+) in the tab bar. Click a tab to make it the active workspace window layout.

You can customize the name of a tab by double-clicking on the existing name. For example, in Figure 8-2 is customized for a debug workflow. The first tab contains a source editor for ListDocumentViewController.swift. The name of the next tab is customized to Debugger. The name of the third tab is also customized and shows a storyboard. The final tab shows a view debugger.

Figure 8-2Window tabs image: ../Art/XC_O_window_tabs_2x.png

Create a new workspace window from a tab by dragging it out of the tab bar. Move the tab to a different workspace window by dragging it into a window.