Menu Command Shortcuts (By Menu)

Each table in this section lists the commands in an Xcode application menu and the keyboard shortcuts associated with each command. Entries appear in the order in which they appear in the menu. The following tables are available:

Table 1-1  Xcode menu command shortcuts

Command

Key Binding

Shortcut

About Xcode

 

 

Preferences…

⌘,

Command-,

Hide Xcode

⌘H

Command-H

Hide Others

⌥⌘H

Option-Command-H

Show All

 

 

Quit Xcode

⌘Q

Command-Q

Table 1-2  File menu command shortcuts

Command

Key Binding

Shortcut

New Tab

⌘T

Command-T

New Window

⇧⌘T

Shift-Command-T

New File…

⌘N

Command-N

New Target…

 

 

New Project…

⇧⌘N

Shift-Command-N

New Workspace

⌃⌘N

Control-Command-N

New Group

⌥⌘N

Option-Command-N

New Group from Selection

 

 

Add Files…

⌥⌘A

Option-Command-A

Open…

⌘O

Command-O

Open Quickly…

⇧⌘O

Shift-Command-O

Close Window

⌘W

Command-W

Close All Windows

⌥⌘W

Option-Command-W

Close Tab

⇧⌘W

Shift-Command-W

Close Other Tabs

⌥⇧⌘W

Option-Shift-Command-W

Close Document

⌃⌘W

Control-Command-W

Close Workspace

 

 

Save

⌘S

Command-S

Save All

⌥⌘S

Option-Command-S

Save Multiple…

⌥⇧⌘S

Option-Shift-Command-S

Save As…

⇧⌘S

Shift-Command-S

Revert…

 

 

Unlock…

 

 

Show in Finder

 

 

Open with External Editor

 

 

Workspace Settings…

 

 

Commit…

⌥⌘C

Option-Command-C

Update…

⌥⌘X

Option-Command-X

Update All

⌃⌥⌘X

Control-Option-Command-X

Merge…

 

 

Discard Changes…

 

 

Add

 

 

Ignore

 

 

Mark as Resolved

 

 

Refresh Status

 

 

Show Repository Status

 

 

Repositories…

 

 

Create Snapshot…

⌃⌘S

Control-Command-S

Page Setup…

⇧⌘P

Shift-Command-P

Print…

⌘P

Command-P

Table 1-3  Edit menu command shortcuts

Command

Key Binding

Shortcut

Undo

⌘Z

Command-Z

Redo

⇧⌘Z

Shift-Command-Z

Cut

⌘X

Command-X

Copy

⌘C

Command-C

Paste

⌘V

Command-V

Paste Special

⌥⌘V

Option-Command-V

Paste and Match Style

⌥⇧⌘V

Option-Shift-Command-V

Duplicate

⌘D

Command-D

Delete

 

 

Select All

⌘A

Command-A

Find in Workspace…

⇧⌘F

Shift-Command-F

Find and Replace in Workspace…

⌥⇧⌘F

Option-Shift-Command-F

Find…

⌘F

Command-F

Find and Replace…

⌥⌘F

Option-Command-F

Find Next

⌘G

Command-G

Find Previous

⇧⌘G

Shift-Command-G

Use Selection for Find

⌘E

Command-E

Use Selection for Replace

⇧⌘E

Shift-Command-E

Filter in Navigator

⌥⌘J

Option-Command-J

Filter in Library

⌥⌘L

Option-Command-L

Show Fonts

⌃⇧⌘T

Control-Shift-Command-T

Bold

 

 

Italics

 

 

Underline

 

 

Show Colors

Show Spelling and Grammar

⌘:

Command-:

Check Document Now

 

 

Check Spelling While Typing

 

 

Check Grammar With Spelling

 

 

Correct Spelling Automatically

 

 

Show Substitutions

 

 

Smart Copy/Paste

 

 

Smart Quotes

 

 

Smart Dashes

 

 

Smart Links

 

 

Data Detectors

 

 

Text Replacement

 

 

Make Upper Case

 

 

Make Lower Case

 

 

Capitalize

 

 

Start Speaking

 

 

Stop Speaking

 

 

Rename

 

 

Extract

 

 

Create Superclass

 

 

Move Up

 

 

Move Down

 

 

Encapsulate

 

 

Table 1-4  View menu command shortcuts

Command

Key Binding

Shortcut

Project

⌘1

Command-1

Symbol

⌘2

Command-2

Search

⌘3

Command-3

Issue

⌘4

Command-4

Debug

⌘5

Command-5

Breakpoint

⌘6

Command-6

Log

⌘7

Command-7

Show Navigator

⌘0

Command-0

Standard

⌘↩

Command-↩

Assistant

⌥⌘↩

Option-Command-↩

Version

⌥⇧⌘↩

Option-Shift-Command-↩

Show Related Items

⌃1

Control-1

Show Previous History

⌃2

Control-2

Show Previous Files History

⌃⌘2

Control-Command-2

Show Next History

⌃3

Control-3

Show Next Files History

⌃⌘3

Control-Command-3

Show Top Level Items

⌃4

Control-4

Show Group Files

⌃5

Control-5

Show Document Items

⌃6

Control-6

Show Issues

⌃7

Control-7

Add Assistant Editor

Remove Assistant Editor

⌃⇧⌘W

Control-Shift-Command-W

Reset Editor

⌥⇧⌘Z

Option-Shift-Command-Z

Assistant Editors on Right

 

 

Assistant Editors on Bottom

 

 

Assistant Editors on Left

 

 

Assistant Editors on Top

 

 

Assistant Editors Stacked Horizontally

 

 

Assistant Editors Stacked Vertically

 

 

Assistant Editors Stacked Horizontally Right to Left

 

 

Assistant Editors Stacked Vertically Bottom to Top

 

 

Show Toolbar Bar

 

 

Show Tab Bar

 

 

Show Debug area

⇧⌘Y

Shift-Command-Y

Table 1-5  Navigate menu command shortcuts

Context

Command

Key Binding

Shortcut

 

Reveal in Project Navigator

⌘L

Command-L

Open in Adjacent Editor

⌘[<]

Command-[<]

Go Forward

⌃⌘⇢

Control-Command-Right Arrow

Go Forward in Alternate Editor

⌃⌥⌘⇢

Control-Option-Command-Right Arrow

Go Back

⌃⌘⇠

Control-Command-Left Arrow

Go Back in Alternate Editor

⌃⌥⌘⇠

Control-Option-Command-Left Arrow

Jump to Selection

⌘J

Command-J

Jump to Definition

⇧⌘D

Shift-Command-D

Move Focus To Next Area

⌥⌘K

Option-Command-K

Move Focus To Previous Area

⌥⇧⌘K

Option-Shift-Command-K

Interface Builder

Jump to Next Object with Clipped Content

 

 

Jump to Previous Object with Clipped Content

 

 

Source editor

Jump to Counterpart

⌃⌘⇡

Control-Command-Up Arrow

Jump To…

⇧⌘J

Shift-Command-J

Jump to Next Placeholder

⌃/

Control-/

Jump to Previous Placeholder

⌃?

Control-?

Jump to Next Issue

⌘'

Command-'

Jump and Fix Next Issue

⌃⌘'

Control-Command-'

Jump to Previous Issue

⌘"

Command-"

Jump and Fix Previous Issue

⌃⌘"

Control-Command-"

Table 1-6  Editor menu command shortcuts

Context

Command

Key Binding

Shortcut

Data model

Show Grid

 

 

Show Page Breaks

 

 

Add Entity

 

 

Add Fetch Request

 

 

Add Configuration

 

 

Add Attribute

⌃⌘A

Control-Command-A

Add Fetched Property

 

 

Add Relationship

⌃⌘R

Control-Command-R

Import…

 

 

Create NSManagedObject subclass…

 

 

Documentation

Explore Documentation

 

 

Search Documentation

 

 

Documentation Bookmarks

 

 

Zoom In

 

 

Zoom Out

 

 

Actual Size

 

 

Add Bookmark

 

 

History

 

 

Interface Builder

Show Bounds Rectangles

 

 

Show Layout Rectangles

 

 

Snap to Guides

 

 

Live Autoresizing

 

 

Align Left Edges

⌘[

Command-[

Align Right Edges

⌘]

Command-]

Align Top Edges

 

 

Align Bottom Edges

 

 

Align Horizontal Centers

 

 

Align Vertical Centers

 

 

Align Baselines

 

 

Align Horizontal Center In Container

 

 

Align Vertical Center In Container

 

 

Send to Front

 

 

Send to Back

 

 

Send Forward

 

 

Send Backward

 

 

Unembed

 

 

Size to Fit

⌘=

Command-=

Add Horizontal Guide

⌘_

Command-_

Add Vertical Guide

⌘|

Command-|

Reveal in Document Structure

 

 

Simulate Document

 

 

PDF

Automatically Resize

 

 

Zoom In

 

 

Zoom Out

 

 

Actual Size

 

 

Single Page

 

 

Single Page Continuous

 

 

Two Pages

 

 

Two Pages Continuous

 

 

Next Page

⌥⌘⇣

Option-Command-Down Arrow

Previous Page

⌥⌘⇡

Option-Command-Up Arrow

RTF

Insert Page Break

 

 

Insert Line Break

 

 

Insert Paragraph Break

 

 

Show Ruler

 

 

Add Link…

 

 

Allow Hyphenation

 

 

Scripting definition

Make Text Bigger

⌘+

Command-+

Make Text Smaller

⌘-

Command--

Source code

Show Completions

⌃\

Control-\

Edit All in Scope

⌃⌘E

Control-Command-E

Fix All in Scope

⌃⌘F

Control-Command-F

Show Issue

 

 

Show All Issues

⌃⌘M

Control-Command-M

All Issues

 

 

Errors Only

 

 

Balance Delimiter

 

 

Re-Indent

 

 

Shift Right

⌘]

Command-]

Shift Left

⌘[

Command-[

Move Line Up

⌥⌘[

Option-Command-[

Move Line Down

⌥⌘]

Option-Command-]

Comment Selection

⌘/

Command-/

Fold

⌥⌘⇠

Option-Command-Left Arrow

Unfold

⌥⌘⇢

Option-Command-Right Arrow

Unfold All

 

 

Fold Methods & Functions

⌥⇧⌘⇠

Option-Shift-Command-Left Arrow

Unfold Methods & Functions

⌥⇧⌘⇢

Option-Shift-Command-Right Arrow

Fold Comment Blocks

⌃⇧⌘⇠

Control-Shift-Command-Left Arrow

Unfold Comment Blocks

⌃⇧⌘⇢

Control-Shift-Command-Right Arrow

Focus Follows Selection

 

 

Show Invisibles

 

 

Xcode project

Add Target…

 

 

Hex editor

Overwrite Mode

⌥⇧⌘O

Option-Shift-Command-O

Table 1-7  Product menu command shortcuts

Command

Variant

Key Binding

Shortcut

Run

⌘R

Command-R

Run…1

⌥⌘R

Option-Command-R

Test

⌘T

Command-T

Test…1

⌥⌘T

Option-Command-T

Profile

⌘I

Command-I

Profile…1

⌥⌘I

Option-Command-I

Analyze

⌃⌘B

Control-Command-B

Analyze…1

⌃⌥⌘B

Control-Option-Command-B

Archive

Build For

Build For Running

⇧⌘R

Shift-Command-R

Build For Testing

⇧⌘U

Shift-Command-U

Build for Profiling

⇧⌘I

Shift-Command-I

Build for Archiving

Perform Action

Run Without Building

⌃⌘R

Control-Command-R

Test Without Building

⌃⌘U

Control-Command-U

Profile Without Building

⌃⌘I

Control-Command-I

Build

⌘B

Command-B

Clean

⇧⌘K

Shift-Command-K

Clean Build Folder…

⌥⇧⌘K

Option-Shift-Command-K

Stop

⌘.

Command-.

Debug

Pause

⌃⌘Y

Control-Command-Y

Step Into

F7

Function 7

Step Over

F6

Function 6

Step Out

F8

Function 8

Step Into Thread

⌃⇧F7

Control-Shift-Function 7

Step Into Instruction

⌃F7

Control-Command-Function 7

Step Over Thread

⌃⇧F6

Control-Shift-Function 6

Step Over Instruction

⌃F6

Control-Function 6

Add Breakpoint at Current Line

⌘\

Command-\

Activate Breakpoints

Deactivate Breakpoints

⌘Y

Command-Y

Shared Libraries...

 

 

Clear Console

⌘K

Command-K

Window Behavior

Normal

 

 

Xcode Behind

 

 

Xcode In Front

Edit Scheme…

⌘<

Command-Less Than

New Scheme…

 

 

Manage Schemes…

 

 

1 Opens the scheme editing dialog for editing prior to performing the chosen command.

Table 1-8  Window menu command shortcuts

Command

Key Binding

Shortcut

Minimize

⌘M

Command-M

Zoom

 

 

Select Next Tab

⌘}

Command-}

Select Previous Tab

⌘{

Command-{

Welcome to Xcode

⇧⌘1

Shift-Command-1

Organizer

⇧⌘2

Shift-Command-2

Bring All to Front

 

 

Table 1-9  Help menu command shortcuts

Command

Key Binding

Shortcut

Xcode Help

 

 

Xcode 4 Transition Guide

 

 

Quick Help

⌃⌘?

Control-Command-?

Search Documentation for Selected Text

⌃⌥⌘/

Control-Option-Command-/

Developer Documentation

⌥⌘?

Option-Command-?