Menu Bar Definitions

The menu bar contains a collection of menus allowing you to manipulate Instruments and recorded data. Each menu contains a list of commands that have been grouped by function.

Instruments Menu

The Instruments menu provides commands for displaying the Instruments window.

Table 2-1  Instruments menu

Command

Description

About Instruments

Provides version information for Instruments.

Preferences

Opens the Preferences dialog.

Services

Opens the Keyboard dialog set to the Services keyboard shortcuts.

Hide Instruments

Hides all Instruments windows.

Hide Others

Hides all displays except for Instruments.

Show All

Displays all hidden processes.

Quit Instruments

Closes all trace documents and shuts down Instruments. User are asked whether they want to save any unsaved data.

File Menu

The File menu provides commands for creating, importing, saving, and running trace documents.

Table 2-2  File menu

Command

Description

New

Creates a new trace document.

Open

Opens a saved trace document.

Open Recent

Opens a recently saved trace document.

Import Data

Opens the Import Trace dialog allowing you to load previously saved data.

Get Info

Opens the configuration dialog for the selected instrument.

Close

Closes the selected trace document.

Save

Saves the selected trace document. Asks for a name and destination if this is the first time the trace document has been saved.

Save As

Saves the selected trace document in a designated location.

Save As Template

Saves the current collection of instruments as a trace template. Trace templates can be accessed from the Instruments starting dialog.

Record Trace

Records trace data using the current instruments.

Pause Trace

Pauses the currently running trace.

Loop

Determines if the user interface recorder will loop during play back to repeat the recorded steps continuously.

Record Options

Opens the Record Options dialog. Allows you to set the start delay, time limit, window limit, if data is collected in deferred mode.

DTrace Data Import

Allows you to import previously collected DTrace data.

DTrace Script Import

Allows you to import previously created DTrace scripts.

Import Energy Diagnostics from Device

Imports the energy logs from an iOS device.

Re-Symbolicate Document

Opens the symbolication dialog. Allows you to set the paths and files used when looking for symbols.

Edit Menu

The Edit menu provides commands for text manipulation, including spelling, grammar, and search capabilities. You can also re-symbolicate a trace document.

Table 2-3  Edit menu

Command

Description

Undo

Removes previously typed instructions.

Redo

Applies instructions previously removed by Undo.

Cut

Removes the selected text from the document.

Copy

Copies the selected item to the Clipboard.

Deep Copy

Copies the selected item and all of the items contained in it on to the Clipboard.

Paste

Pastes the current information stored on the Clipboard into the selected document.

Paste and Match Style

Pastes the current information stored on the Clipboard into the selected document and uses the document’s style information for the data.

Delete

Deletes the selected item.

Select All

Selects all available items.

Find

Allows you to search for an item. Contains five suboptions:

  • Find: Opens the search field and looks for the first instance of the input text.

  • Find Next: Opens the search field and looks for the next instance of the input text.

  • Find Previous: Opens the search field and looks for the previous instance of the input text.

  • Use Selection to Find: Opens the search field and uses the highlighted selection as the input.

  • Jump to Selection: Jumps to the current selection.

Spelling

Provides spelling and grammar options for the document. Contains three suboptions:

  • Show Spelling and Grammar: Opens the Spelling and Grammar dialog.

  • Check Spelling: Performs a spell check on the document.

  • Check Spelling While Typing: Performs a spell check while typing in the document.

Add Flag

Adds a new flag to the track pane.

Remove Flag

Removes an existing flag from the track pane.

Special Characters

Opens the Characters window.

View Menu

The View menu provides commands for manipulating the Instruments window.

Table 2-4  View menu

Command

Description

Instruments

Opens and closes the Instruments pane.

Detail

Opens and closes the Detail pane.

Extended Detail

Opens and closes the Extended Detail pane.

Run Browser

Toggles browser mode on and off.

Full Screen

Toggles Instruments in and out of full screen mode.

Mini Instruments

Toggles Instruments in and out of mini mode.

Inspect Flag

Opens the flag dialog.

Next Flag

Jumps to the next flag in the track pane.

Previous Flag

Jumps to the previous flag in the track pane.

Decrease Deck Size

Decreases the height of the instrument.

Increase Deck Size

Increases the height of the instrument.

Snap Track To Fit

Resizes collected data so that it fits exactly inside of the track pane.

Shuttle Left

Not used.

Shuttle Right

Not used.

Hide Toolbar

Hides the Instruments toolbar.

Customize Toolbar

Opens the Instruments toolbar dialog.

Instrument Menu

The Instrument menu provides commands for collecting and recording trace data.

Table 2-5  Instrument menu

Command

Description

Build New Instrument

Opens the Build Instrument dialog.

Edit Instrument

Opens the Build Instrument dialog filled with the selected instrument’s information.

Delete <Instrument Name> Instrument

Removes the selected instrument from the trace document.

Delete Run <#>

Deletes the selected data collection run from the trace document.

Trace Symbol

Brings up the trace symbol dialog. Allows you to trace a specific symbol.

Enable Recording

Allows you to record data.

Export Track for <Instrument name - process>

Saves the collected information for the instrument / process combination listed.

Compare Call Trees

Compares the call tree of the current run with the call trees of previous runs.

Call Tree Data Mining

Allows you to manipulate the call tree in the Detail pane.

Window Menu

The Window menu provides commands resizing the Instruments window along with managing flags and PM events.

Table 2-6  Window menu

Command

Description

Minimize

Minimizes the Instruments window to the dock.

Zoom

Enlarges the Instruments window to the size of your video monitor while leaving the menu bar available.

Library

Opens and closes the Library pane.

Manage Flags

Opens the Flag dialog. You can edit flag information from this dialog.

Manage PM Events

Opens the PM Events dialog. You can choose PM events to monitor from this dialog.

Bring All to Front

Brings all Instruments windows to the front of the screen.

Instruments<#>

Makes the selected Instruments instance active.