Unit Testing Apps and Frameworks

Last Revision:
Version 1.2, 2014-09-29
Updated to use XCTest and Modern Objective-C syntax. iOS_Calc now supports Storyboards.
(Full Revision History)
Build Requirements:
Xcode 5, iOS 7.0 SDK or later, OS X SDK 10.8 or later
Runtime Requirements:
iOS 7 or later, OS X 10.8 or later

Shows how to build a static library for an iOS app and a Mac app, how to implement and run logic unit tests on the library source code on each platform, and how to implement and run application unit tests for the apps.