Creating App Previews with Final Cut Pro X

Final Cut Pro X combines power and flexibility to let you create great app previews. Start by capturing screen recordings from your iOS device or Apple TV with QuickTime Player on your Mac. Next, you’ll use Final Cut Pro to edit the recordings and add titles, transitions, a soundtrack, and voiceover.

To learn about App Store guidelines for app previews, read Show More with App Previews and see App Store Connect Help.

System Requirements

  • iOS device with Lightning connector, Retina display, and iOS 9 or Apple TV (4th generation)
  • Mac with OS X v10.10.5 Yosemite or later
  • Final Cut Pro X v10.1.3 or later

Capture Screen Recordings with QuickTime Player

  1. Connect your iOS device or Apple TV to your Mac using a Lightning cable (iOS device) or USB-Type C cable (Apple TV).
  2. Open QuickTime Player on your Mac.
  3. Choose File > New Movie Recording.
  4. In the window that appears, select your device as the Camera and Microphone input source.

Create an App Preview with Final Cut Pro X

Import Screen Recordings

Import the screen recording files that you captured with QuickTime Player.

  1. Launch Final Cut Pro.
  2. Create a new library for your preview video by choosing File > New > Library.
  3. Import the video files by choosing File > Import > Media.

Create an App Preview Project

  1. Create a new project by choosing File > New > Project.
  2. Name the project and choose Use Custom Settings.
  3. Choose Video Properties: Custom.
  4. From the Format pulldown menu, choose Custom.
  5. Change the Rate to 30p.
  6. Change the Resolution to match your screen recording files. See App Preview Specifications.

Add Clips

  1. Click a video clip in the Browser at the top left of the Final Cut Pro interface.
  2. Drag the clip to the timeline.
  3. After a clip is in the timeline, you can make it shorter or longer by dragging either of its edges.

Add Titles

Apple-designed app preview titles are available as a free download from the Apple Developer website.

  1. Click the Title Browser button in the center toolbar.
  2. Select the App Preview category of titles.
  3. To make a title appear over a video clip, drag it above the clip in the timeline. To make a title appear over black or a background color, drag it directly to the timeline.
  4. Select the title in the timeline, then double-click the text in the Viewer and type your text.
  5. Choose Window > Show Inspector to open the Inspector, where you can customize the font and color of a title.

Add Transitions

  1. Click the Transitions Browser button in the center toolbar.
  2. Drag a transition before or after a clip in the timeline.
  3. Adjust the duration of a transition by dragging the edge of the transition icon in the timeline.

Create a Soundtrack

  1. Click the Music and Sound Browser button in the center toolbar.
  2. Click to select a sound library, then select the audio file you’d like to add.
  3. Drag the file underneath a video clip in the timeline.

Record Voiceover

  1. Choose Window > Record Voiceover.
  2. In the window that appears, click the Record button.
  3. Your voiceover audio clip will be automatically connected to video in the timeline.

Export Your App Preview

  1. Select the finished project in the Browser.
  2. Choose File > Share > Master File.
  3. Click the Settings tab and confirm that the Video codec is H.264.
  4. Click the Next button and choose where to save your finished preview.

Learn More

To learn more about using Final Cut Pro X, visit Final Cut Pro X Help.

Additional training resources are available on the Final Cut Pro X Resources page.