My App build process properly working with XCode 9.2, but after updating to the latest XCode 9.4.1, linker error shown. Details are given below

Dear Team,


Thanks in advance,


Please advise how to resolve this issue in XCode 9.4.1. App was working and build has successed in XCOCDE verison 9.2, issue only in XCode Version :- 9.4.1


Mac OS version :- 10.13.6

XCode Version :- 9.4.1


ld: warning: ld: warning: ignoring file /usr/lib/system/libsystem_kernel.dylib, missing required architecture arm64 in file /usr/lib/system/libsystem_kernel.dylib (2 slices)

ignoring file /usr/lib/system/libcache.dylib, missing required architecture arm64 in file /usr/lib/system/libcache.dylib (2 slices)

ld: in '/usr/lib/system/libcache.dylib', missing required architecture arm64 in file /usr/lib/system/libcache.dylib (2 slices) for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)


Sincerely,

Talish

Post not yet marked as solved Up vote post of prasobac1 Down vote post of prasobac1
2.1k views

Answers

I’m not sure how you got into this situation, but you seems to be linking with the macOS implementation of these dynamic libraries rather from the stub libraries in your iOS SDK (in recent Xcode’s stub libraries have a

.tbd
extension). Moreover, you shouldn’t need to link with these libraries directly anyway. My recommendation is that you track down the source of this linkage (probably a build setting) and remove it.

Share and Enjoy

Quinn “The Eskimo!”
Apple Developer Relations, Developer Technical Support, Core OS/Hardware

let myEmail = "eskimo" + "1" + "@apple.com"

Check not to have `/usr/lib/system` among your LIBRARY_SEARCH_PATHS in your projects build setting