Could not find developer disk image for iOS 9.1

After dags of nagging by iOS, I upgraded my phone and iPad to iOS 9.1 from the last beta. Then I upgraded to the GM seed for El Capitan and got the latest Xcode 7.0 (7A218), but now I'm getting the message "Could not find developer disk image" when I connect my device. After reading similar issues on StackOverflow, I went and checked in /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport, and sure enough I see supported platforms only up through 9.0 (13A340). It's not in my last Xcode beta folder either.

Post not yet marked as solved Up vote post of BrianStewart Down vote post of BrianStewart
72k views

Answers

You need to be using the (pre-release) Xcode 7.1 in order to work with (also pre-release) iOS 9.1 devices.

I want ot go back to official iOS 9.0.2


how to do that?

I restored my device back to iOS 9.0.2. Want to use the
stable XCode Version 7.0.1 (7A1001), but now this device

is not regnized in XCode 7.0.1. Only recognized in Xcode

beta 7.1. I want to submit for Review and can only do that

from XCode Version 7.0.1. Please advise.

I am not sure about this - Are you implying that you are running a beta version of iOS on your device?


If so- perhaps you have to remove your beta provisioning profile from your device.

on iOS device:

Settings >general >profile >tap the config profile name > at bottom in red "Delete Profile"


maybe then soft reset your iOS device.


Then when running the current released version of Xcode, connect your device and give it the default provisions or the ones you select from the Xcode interface


Does this make sense?

https://developer.apple.com/ios/download/

Above link says we can't. 😢


=========

iOS 9.1

This is the release version of iOS 9.1 for iPad, iPhone, and iPod touch. Devices updated to iOS 9.1 can not be restored to earlier versions of iOS.


========

I think by now everyone figured too.

So on Oct 21 Apple released iOS 9.1 with xcode 7.1.

Together I no longer have this "ineligible" or "unavailable" device problem.


Following is for the future reference.

For people who would have similar problems in the future,

beware that this problem is fundamentally rooting from the mismatch of your iOS version and xcode version.

Check the compatibility of iOS and xcode.

Everyone except me. I upgraded from ios9 to 9.1 and from xcode 7 to 7.1 and i have this problem on two computers(although on one of them the error is that i should try a restart). I can't really tell where is the problem, you'd say on the phone, but none of the xcodes has the disk image for 9.1 (/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport)


Can you check if you have it? And perhaps send it to me? cristi.baluta at gmail dot com

Thanks

Ok, problem solved. I took a closer look and 7.1 was not installed, the appstore was reporting wrong. I made this update on 23oct, and today i see a new update on the 21st of oct, how weird? I updated to this version and now i indeed have 7.1. There is something wrong with apple anyway, only buggy software latelly, it showed me 3min to install, then it stayed 30min and gave an unknown error, but the xcode is installed.

how did you installed ?

I have downloaded the update from the appstore (Xcode 7.1), but when i open XCode it still runs the version 7.0.1 that i previously had

Be sure to wait for the download and installation to finish - check LaunchPad for progress.


Still no joy, restart your computer so the MAS application can take a fresh swing at the process.

Xcode automatically updated for me yesteday. I'm getting this error today and I'm not able to run applications on my device.

I know this post is about iOS 9, but If you are having this issue with Xcode 7 and iOS 10 or iOS 10.1, this solved the issue:

https://3-screens.com/2016/working-with-ios-10-and-above-on-xcode-7/

The URL to the article has changed.

https://3-screens.com/2016/working-ios-10-xcode-7/