A QWERTY keyboard is not shown when typing a password in iOS14.2.

Normally if we set a content type of a text field as .password or .newPassword, a QWERTY keyboard is shown.
In iOS14.2, if we tap a password text field(It means the text field which isSecureTextEntry is true) in the screen which has 3 or more text fields(At least two of them have true isSecureTextEntry), we don't show a QWERTY keyboard but a Japanese one and can't do flick input.
I'm not sure it's only Japanese keyboard problem but I found others have faced it.
Post not yet marked as solved Up vote post of hideee Down vote post of hideee
3.0k views

Answers

I met this situation same as you. (I'm setting language as korean.)
it has just happened after installing iOS14.2.
I had the same problem.
In my case, I use 3 TextFields.
The first and second use .name for the TextField type, and the third specifies .password.
In this case, changing the TextField type from .name to .username solved the problem.
I still don't understand why .name causes problems.

I still don't understand why .name causes problems.
I'm glad if you can use it as a reference.
It also happens in iOS14.3(My language is Japanese).
Also this occurred when the TextField type was username.
Same here.
In my case, when I changed a text content type to UITextContentTypeOneTimeCode, it was solved.
But this unable a password auto-fill function so it's not the best solution.
I'm still waiting for the apple developer's fixing.
In my case, Everything is fine in LoginViewController, but in SignUpViewController, this issue happened
I solved it by rename SignUpViewController to SUpViewController. A magic!!! I don't know why it works
Is this problem solved?
I have 3 TextFields in SignUpViewController, also acing this issue too, so frustrating.
We have tried:
  1. Renaming SignUpViewController to other names.

  2. Change password field and verify password filed's textContentType to .oneTimeOnly

didn't resolve the issue.

It seemed to be fixed in iOS 14.5 beta 3.
It's kind of the same issue guys
I fixed this bug by rename SignUpViewController to another name

https://stackoverflow.com/questions/52701160/native-uitextfield-secure-text-entry-forces-english-us-keyboard/53760545
I used two UITextFields to fix this issue.

https://gist.github.com/shalyf/a91bc663c823b040ce15d656a84ce93c
I've checked iOS 14.5 version that release 27th Apr(JST). It seems looks great as expected about password form.