Simulator device not showing in Safari develop tool

Hi weveryone!


First, here's my settings:

MacBook Pro (Retina, 13-inch, Mid 2014)

macOS Sierra 10.12.1

Safari 10.0.1

Xcode 8.1

Simulator 10.0


When I launch, say, the iPhone SE simulator, open a web page in Safari mobile, I don't see the Simulator device in Safari/develop tool menu

Used to work on Yosemite.


anybody has the same problem?

Post not yet marked as solved Up vote post of PatricedeMTL Down vote post of PatricedeMTL
65k views

Answers

I'm having the same issue with almost the same configuration except I'm still on El Capitan (10.11.6). A colleage of mine hasn't had any issues with XCode 8.0. Were you able to resolve this?

I have the same issue with the same configuration, and cannot resolve it. However, I installed Safari Technology Preview and the simulator shows up correctly in the Develop menu in that.

https://developer.apple.com/safari/technology-preview/


Hope that helps.

I downloaded it and nothing changed.

here's a screenshot of my desktop: http://138.197.140.31/img/xcode-simulator-safari-develop.jpg

You sure you have the same configuration?

No. Still having the problem.

Finally fixed it..

I simply restarted Safari! I dunno for sure but I probably didn't restart Safari after updating to xcode 8.1


Hope that helps!

I'm having the same problem since upgrading to macOS Sierra and XCode 8.1. The Simulator starts the program, but Safari's Develop menu doesn't show the Simulator device. Web Inspector is turned on in Settings->Safari->Advanced on the simulated device, but that doesn't help. I tried reseting everything, and still no luck. The Develop menu works with real devices attached. Please advise.

Have you tried simply relaunching Safari after Simulator starts running?


I find that Simulator is always in Safari's Develop menu if it's already running when Safari launches, and Simulator is never in the menu if Safari is launched first. That's Simulator 10.0 (comes with Xcode 8.1), Safari 10.0.1 and OS X 10.11.6.

Thanks, goldsdad. That really worked!

Worked for me as well, thanks @goldsdad!

Worked for me too!!! Thanks a lot

None of the solutions worked but after restarting my computer I was able to inspect the simulator from Safari Technology Preview

It worked like a charm.

Now I know! Thanks a lot!!