Launch Screen Image not Updating!!!

Hi, I am a iOS developer. I have an iOS app currently running in Appstore. I am in the process of updating the app’s Launch image. Previously the app had a Launch screen image which was added in LaunchScreen.xib and in the update I want to change the Launch screen image. If I try to use the same xib with different image, the app takes the previous image as Launch screen image. I also tried using completely new xibs and image assets but the splash screen becomes a blank white screen in this case. Any helps to fix this will great.

Post not yet marked as solved Up vote post of krreddy888 Down vote post of krreddy888
33k views

Answers

After juggling images, be sure to use Xcode's 'Product' menu with the option key pressed, then choose to 'clean build folder'.

Post not yet marked as solved Up vote reply of KMT Down vote reply of KMT

Thanks for the reply KMT. I have tried cleaning the build folder too, but it doesn't help. If I uninstall the app, restart the phone and then install the app again, it works corretly. I think some issue with the app cache. Could you help me in that.

Hi, have you found a solution?

Many thanks!

I found only this solution: remove app -> reload phone -> install app

Unfortunately this is a problem that can affect even production user.

https://stackoverflow.com/questions/33002829/ios-keeping-old-launch-screen-and-app-icon-after-update

Did you find a solution for this? We face the same issue. We also reported this bug. Wrote about it here: https://forums.developer.apple.com/message/321239#321239

This worked for me: http://arsenkin.com/launch_screen_image_cache.html


"Again, thanks to the thread I have referenced above I found a way to solve this issue - name your new image differently from the one there was before in case your new one has the same name as the old one and put it out of the *.xcassets folder to the project directory and reference it in your UIImageView. And that's it. Sound ****** easy but oh gawd how much rage I had."

Without reloadng phone working too.
Delete app -> Clean Build Folder -> Build

The only workaround that works for me was to add the images outside Images.xcassets folder. After modified this and rebuild the app, it worked expected.
Some issue it's happening on the iOS 14 or XCode 12.
A workaround suitable for testing is to temporarily change the Bundle Identifier of your app. This way your phone/simulator will treat that app as a new app for which the cache doesn't exist yet.
I found that the simplest way is to put the image under the project-root.