Xcode 11 can't find app icons source

Hello, I just update to xcode 11, and all the apps that have sticker pack extention are having this issue

if you select the target and go to the general tab, at the bottom in the app icons source, the source is showing in red and if you try to update and select again, is trying to select the app icon of the main target

Accepted Answer

Hello guys, here is a quick solution :

  • delete your current stickers target, and create one from scratch
  • change the name of the Stickers Icon, from "IMessage App Icon" to "AppIcon"
  • add all your stickers images and icon images
  • select "AppIcon" in the App Icon Source of the Stickers target

Answers

Looks like it's Xcode 11 bug. I am just keeping it red.

Having the same issue here, the stickers asset is not appearing in the dropdown selection, and if you keep it *red* (not found) the app wont show them when you run it 😟

Same issue here, have you found a work-around?

Similar issue here, but with a tvOS project.

Yes, I see this with a tvOS project too.


When I uploaded a build to Testflight earlier the icon was showing incorrectly inside the Testflight app on the Apple TV, I'm guessing caused by this issue.


I also tried rebuilding the asset catalogue, i.e. deleting it from Xcode and creating it again, populating it etc, and then specifying it in the Asset Catalogue Compiler options, but I get the same result.

Also, just to add that this also happens on a newly created tvOS single-view project, so hopefully it'll be an easy one for Apple to fix.

It's have been two days already I'm stuck because of this bug. The iMessages extension application sees only AppIcon assests. not the iMessage App Icon assests which it needs. I did not keep it in red and changed it without knowing that I would not be able to revert it back.
As long as it accepts AppIcon assets I though that they've change so iMessage extension apps does not need the iMessage App Icon type asset. But when I tried to upload app on App Store, it gave me errors which said it needed.


I've asked question on stackoverflow if you guys find way around plase tell me. I've tried everythin today.
https://stackoverflow.com/questions/58146194/xcode-11-cant-see-app-icons-pack-of-imessages-extension-after-update

Hello guys, here is a quick solution :

  • delete your current stickers target, and create one from scratch
  • change the name of the Stickers Icon, from "IMessage App Icon" to "AppIcon"
  • add all your stickers images and icon images
  • select "AppIcon" in the App Icon Source of the Stickers target

I'm having the same issue 😟 Does anybody have the solution to this problem???

This works for tvOS as well. I had to fiddle a bit, like telling Xcode not to use asset catalog, then reopen the project, then select "Migrate to asset catalog", then remove the duplicate the AppIcon asset Xcode created. And finally it worked. See also https://stackoverflow.com/questions/37263516/tvos-icon-not-showing

I'm getting this red error as well in Xcode 11.1. Doing the suggested steps in the original post doesn't work for me. As that links to an App Icon set not a Stickers Icon set. It seems the dropdown box is filtering the wrong type of icon set.

Having the same problem and the workaround listed below doesn't work. It destroys my main app icons when I do this.

Update: The workaround only works in the current Xcode session. Restarting Xcode it can't find the app icon again :/

This is happening to me, as well. There's absolutely no fix.


It is definitely an Xcode 11 issue. A project that I made in Xcode 10, and that worked fine, is having the same issue in 11.


I have to wait for Apple to fix this. I won't report the bug, because there's obviously been multiple reports by now.


This is not a "showstopper" for me, right now.

Hi everyone, with the Xcode 11.3 beta version the problem has been solved. We hope that they will release this new version as soon as possible.