dyld: Library not loaded. Image not found

Help!! I have been trying to resolve this issue for days now. Been to every forum. I'm getting this error


dyld: Library not loaded: /Library/Frameworks/Vorbis.framework/Vorbis

Referenced from: /private/var/mobile/Containers/Bundle/Application/

Reason: image not found


So frustrated.... And yes I have tried embedded binaries, copy files, etc.


Works fine on simulator, but this error pops up when I try to run it on device. (ipad iOS 8.3. Using latest xCode)

Post not yet marked as solved Up vote post of BBKUser Down vote post of BBKUser
32k views
  • Go to Build Settings ---> Build options ---> valid workspace --> yes

    The above issues will be fixed.

Add a Comment

Answers

This is happening to me too. It only happens on devices running ios 8.

I have this same exact issue. Cleaning the build doesn't fix it, the binaries are loaded and set to copy. Runs fine in the iPad simulator, but fails on the actual device. A real pain.

Are you building Vorbis.framework yourselves, or are you getting it prepackaged. It looks to me like it was built incorrectly. It has a dylib id of /Library/Frameworks/Vorbis.framework/Vorbis, and there's no way for you to install it into that location on a device. It should be @rpath-relative or a static library that gets linked into your executable.

Thank you, solved a very annoying issue for me. For some reason, well into the development of a Swift 2.3 custom Framework, Xcode 8 had removed the DYLIB_INSTALL_NAME_BASE setting from the project.pbxproj file. A little walk into the Build Settings / "Dynamic Library Install Name Base" setting back to "@rpath" fixed it.

I am having the same issue on Xcode 9.3:

dyld: Library not loaded: @rpath/libswiftCore.dylib

Referenced from: /var/containers/Bundle/Application/7A0A3383-BA7B-42F8-B52D-72952451F4B7/UdacityMemeV1.app/UdacityMemeV1

Reason: no suitable image found. Did find:

/private/var/containers/Bundle/Application/7A0A3383-BA7B-42F8-B52D-72952451F4B7/UdacityMemeV1.app/Frameworks/libswiftCore.dylib: code signing blocked mmap() of '/private/var/containers/Bundle/Application/7A0A3383-BA7B-42F8-B52D-72952451F4B7/UdacityMemeV1.app/Frameworks/libswiftCore.dylib'

(lldb)


I have made mulitp changes to the target settings in Build Options for Embed Asset Packs in Product Bundel and Enable On Demand Resources, but the app still freezes on the launch screen on my ip8+

Thanks gebasezen,


Although I'm using objective c, this fixed the issue for me 🙂