Am I using search wrong in iPadOS 14?

I can’t figure out how to get it to search anywhere except on Safari. Unlike prior versions, where searching for an app by name would show the app on my iPad or in the app store, I now only see websites in the search results.

For instance, I have the Youtube app on my iPad. but if I search “youtube” the app is not in the search results. I only get “youtube.com” etc. And when I try to search for my banking app, it only shows me the bank's website URL.

And yet, I see many online say that the new search is great as an app launcher. Yes, it is if the app you want is something frequently or recently used... as it will show up in the Siri Suggestions... but not when you're trying to search for the app on the iPad.

I must be doing something wrong here, but can't figure out what.
Post not yet marked as solved Up vote post of jackster12 Down vote post of jackster12
667 views

Answers

I have the exact same issue. Before the most recent beta I was able to fix it based the only thing I could think of, which is number of apps installed. I had a pretty significant number of apps installed so I guessed it was a bug in indexing for spotlight. Unfortunately after the last beta update it went back to not breaking. I've submitted feedback during the first beta, and have kept updating it, but still says there is no other reported cases for this issue. I'm at a loss for what to try next, and you're the first person I've found with this same problem, and like you, I only ever read how great spotlight was for everyone else, meanwhile I'm grinding my teeth.

Another thing I tried that didn't fix it was erasing my device, restoring back to iOS 13 non-beta (search worked), then upgrading again to iOS 14 Beta and search was still broken. I'm sure Apple doesn't read these posts, but just in case the FB ID is: FB7871373.

Matthew
It’s somewhat of a relief to know someone else is having the same issue. However, it feels like the kind of thing that’s baked into the OS, not an install error. It’s as if Search is only programmed to look into Safari results, nothing else. I’ve sent a Feedback message to Apple too, along with a screenshot. Let me know if you hear about anything. It’s literally the only thing I can find wrong with the beta, but it’s a big enough problem that it sours the whole experience.
I am having exactly same issue and I too have a significant number of apps (>1000) installed and that’s likely the problem. As you can imagine it’s quite a pain and I hope will get some attention in the next update. My iPhone has a lot (~600) but it seems to work as expected and finds the apps as well.
And still an issue with beta 5.
14.0.1 GA fixed this issue !!!!
Same problem here. STILL with beta 7.2.