Big Sur DNS Issue

Hi,

Since updating to Big Sur i've had this strange error, that i've been debugging to try and help out a bit with this error i'm getting with local DNS.

I use Docker/Kubernetes locally to run a particular application at a series of particular domains via the browser. I do this by adding local IPs to the Network/(Adapter)/DNS/DNS Servers and having the last item be 8.8.8.8 so it would pick up the local docker container DNS first and fall back etc.

Upon upgrading (from Catalina) I noticed that these were not working.
so did the normal things of flushing DNS, clearing cache etc. Then it would work, but only for a small period of time after a DNS flush using:

Code Block
sudo killall -HUP mDNSResponder

So i would have a small window where i could access these, and once on the domain it seemed to be fine and would stick the DNS to the correct DNS Server IP, however all other local domains would fail, but if i run the flush DNS command again it would allow me onto the failed domain again.

I naturally debugged all my containers and they are working as intended as seen via the fact they're responding correctly some of the time, but as it requires a DNS flush it seems like there is more of an issue there.

Has anyone else had any issues using DNS servers, and does anyone have an advice for maybe debugging this further?

Thanks!
Post not yet marked as solved Up vote post of mdsmash Down vote post of mdsmash
2.0k views

Answers

I'm having DNS issues in macOS Big Sur. I described the issues here: https://developer.apple.com/forums/thread/670856
Updates should NEVER break DNS!!!

I have this issue with the latest Cisco Anyconnect & Big Sur update as of 2021-07-19.

For me, the sudo killall -HUP mDNSResponder is inconsistent and works only for a few minutes. A better solution for me is to use Google (or cloudflare DNS) servers.

  1. Go to Settings -> Network -> Advanced -> DNS tab
  2. Click '+', then add server 8.8.8.8
  3. Delete any other DNS servers in this list by selecting them and pressing '-' (minus)
  4. Click OK, then Apply, then restart.

I haven't encountered any problems with this approach so far.