Unable to install app: BundleID issue

I am trying to add widget extensions to my existing watch app which is in turn attached to an iOS app. I am getting this error:

Please try again later.

Unable To Install “nextBellWatch” Please try again later. WatchKit 2.0 app's bundle ID com.seanmccomas.nextBellSingleView.watchkitapp is not prefixed by the parent app's bundle ID followed by a '.'; expected prefix .

Here are my bundle IDs:

iOS App: com.seanmccomas.nextBellSingleView

iOS widget extension: com.seanmccomas.nextBellSingleView.NextBellWidget

watch app: com.seanmccomas.nextBellSingleView.watchkitapp

watch widget extension: com.seanmccomas.nextBellSingleView.watchkitapp.widget

What am I missing?

I feel like I have done everything right.

Post not yet marked as solved Up vote post of Smccomas00 Down vote post of Smccomas00


I have a similar error (Xcode 14). My watchOS dev has been a nightmare so far, just because of the impossibility of testing. The app cannot be installed:

This app contains a WatchKit app with an invalid bundle identifier. The bundle identifier of a WatchKit app must have a prefix consisting of the companion app's bundle identifier, followed by a '.'.

iOS app id : com.me.appname Watch app id : come.me.appname.watchkitapp Note: Xcode 14 does not create a target watch extension anymore.

Have somebody found solution? I faced with in XCode 14 (not beta) and can't figure out. If to remove "Health" capability - everything is fine. But in any case I need access to HealthKit from watch app.

  • I use healkit too

Add a Comment

I'm experiencing this exact issue. Whenever I add health capabilities the watch bundle identifier needs to be changed from ".watchkitapp" but once i change it I get the above issue

I was having the same issue. All of my bundle ids were what it was suppose to be. Additionally, I don't use Health capability. So, I just deleted the WatchOS target, then add it again to the project. You have to write the product name and organization identifier when you are adding it, right? I've realize that the organization identifier that Xcode automatically fills and the parent app's bundle id are different. I corrected the organization identifier and my problem was solved.

The solution in my use case was found here -  https://www.appsloveworld.com/coding/ios/6/watchkit-extension-bundle-identifiers

I had the same experience. Finally I was able to install and run after inputting the Bundle ID of iOS App to WKCompanionAppBundleIdentifier field in Build Settings.

  • This is the correct solution.

Add a Comment