Cannot reorder rows in UITableView under Mac Catalyst

It appears that we are not able to reorder rows in our tables when running our iOS/iPadOS app under Mac Catalyst. It appears that all the delegate methods are returning true indicating the row can be moved and edited. The reordering handles appear in editing move and the row can be moved around (also using drag and drop) but the user interface is not indicating that the row can be dropped to be reordered. It's as if the proposed destination path is being rejected. I tried setting up that delegate method (thinking that maybe the default for that is messed up on Mac Catalyst) but it had no effect. Every table in our system performs this way.

Here is a link to an example video that shows the table view not working: https://onsongapp.s3.amazonaws.com/Reordering%20Example.mp4

Please advise if there is something else that needs to be implemented or changed for Mac Catalyst to properly handle table cell reordering.

Post not yet marked as solved Up vote post of jkichline Down vote post of jkichline
285 views
  • I should also add that the tableView:targetIndexPathForMoveFromRowAtIndexPath:toProposedIndexPath: is never called...

Add a Comment

Replies

I just checked the only place I know of in Ivory for Mac where you can reorder something in a UITableView (settings -> accounts) and it works. Do you have a test app I can look at where it fails?