Apps directory not appearing in iCloud Drive in Finder

Hi,


I have 2 iOS apps with which I tested iCloud Drive.

With the frst one I didn't had any trouble.

I'm able to use the iCloud Drive and files that I store in the ubiquituos container are transferred to the cloud

and I can see the Apps folder and contents in Finder on my iMac.


Now the strange thing is that with the 2nd app I get problems although I have setup everything exactly the same.

The only difference that I can see is that during the initial run of App2 with iCloud entitlements enabled I had forgotten

to add the


  <key>NSUbiquitousContainers</key>
  <dict>
       <key>iCloud.com.***.app2</key>
       <dict>
            <key>NSUbiquitousContainerIsDocumentScopePublic</key>
            <true/>   
            <key>NSUbiquitousContainerName</key>
            <string>App2</string>
            <key>NSUbiquitousContainerSupportedFolderLevels</key>
            <string>Any</string>
           </dict>
  </dict>


in the info-plist file.


I get the feeling that this screwed app the iCloud for this app and even if I now set this up correctly it refuses to work.


Any one experiencing a similar issue?

Or is there any way to reset the iCloud for an app completely and start over again?


One more thing: when using brctl I can see that items are sent/retrieved from the iCloud and they are stored in the

iCloud Drive folder on my Mac. But they are not visible in Finder.

Replies

Same here - any news on that?

I have read that you need to increase the build number after adding the entitlements to iCloud. After doing that, I am able to save a file into the iCloud Drive; however, they are not visible in the Mac finder.

Does anyone know why?

Any solutions for this? I can't figure it out and its driving me nuts

I got this working now with the help from Apple.

In the end it was the CFBundleVersion that need to be increased for every version of the app.

I knew that before and during the problem I described above happened I tried a lot and also tried to

increase the CFBundleVersion. I didn't had any luck, but maybe this was because of some temporary internet

or server issue.

However, because I didn't had any luck, I stepped back to an older CFBundleVersion (a lower one).

And with that bundle version number it was not possible anymore to do any change.


So the solution was to increase the number to something I had not used beforehand for sure.

In my case I increased it to 100.


And afterwards it all started to work.

My application started to work after increasing the Build Number, as you said.


Thank You.

Post not yet marked as solved Up vote reply of tjgo Down vote reply of tjgo

I am able to turn the visibiliy of the iCloud container on and off by changing


NSUbiquitousContainerIsDocumentScopePublic


and then bumping


CFBundleVersion


to tell macos that a change has taken place. This reliably triggers a change in the folder visibility.

Same here, I followed every tip I could find here and on other websites, but still the folder / files are not showing up visibly.

Problem: ubiquitous container works, files can be read and written, but are not showing up in macOS Finder, nor in the Files app on iOS devices.

macOS 11.5, iOS 14.7, Xcode 12.5.1

I have tried:

It is driving me crazy. Who can help?

  • Did you find a solution? Does also not work for me. On my Mac in Terminal I can go the directory and the files are there, but not visible in Finder or the Files app on iOS.

  • I also would like to know if you found the solution to this. This is the most irritating part of using CloudKit. I need a place the user can move files into and out of for my app.

Add a Comment

Here is a tip - and I struggled forever.

create app iCloud containers something like this

com.company.app.dev01

com.company.app.dev02

com.company.app.devxx

com.company.app.prod

If you create the container with the wrong settings than it seems that is it ! You can't get it to show up no matter what you do except create a new one, hence the naming conventions above.

Be sure to set the access as Public in info.plist BEFORE you run the app the first time !!

Also make sure all the identifiers match up in the app entitlements and on the target Signing & Capabilities page and in the apps info.plist.