Xcode Hangs on Installation of Components

Xcode will not successfully install the additional components to support running and debugging. Choosing Install pops a password prompt that can't be authenticated. The password is obviously correct but the box reappears and will not take the password. I have tried reinstalling Xcode from the App Store and running it from Terminal with the -installComponents flag, but to no avail. Any ideas on how to proceed?


Same issue I am facing now. Did you get any response? Please let me know.

Can you please file a bug on this? Please run the following command and attach the output (it may take a few minutes)

spctl -a -t exec -vvv --raw /Applications/Xcode.app

and make sure to mention which version of OS X you are running.

I am getting the same error and please find the requested output.

dev-mac01:/ administrator$ spctl -a -t exec -vvv --raw /Applications/Xcode.app

/Applications/Xcode.app: accepted

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-/

<plist version="1.0">







<string>Apple System</string>



<string>Software Signing</string>







origin=Software Signing

I got the same problem: It hangs, i cant start xcode anymore.

I had the entire bar filled on the part where I'm just installing the last essential components and it hung, wouldn't progress and re-starting the program would require the same screen and hanging.

I read on another forum different things, but one person said that just restarting it would sometimes fix it. I restarted my computer and then XCode just started working. #RestartTheComputer

Try to close xcode via the dock. This worked for me. It restarts like magic.

It is not stucking. but, sometimes it will take too long to respond. So don't worry, give it time and it will open for sure

Please check the dates of posts -- you're replying to someone who had this problem almost three years ago.