apple id not working in simulator

I'm working on an iOS app using CloudKit. I followed Apple's advice in the link below to test in the simulator with a newly created Apple id. This Apple id is working fine for logins in my browser. However when trying to use it in my simulator it keeps telling me the username/password is incorrect, which is really not true.


https://developer.apple.com/library/content/documentation/IDEs/Conceptual/iOS_Simulator_Guide/TestingontheiOSSimulator/TestingontheiOSSimulator.html


I tried the same with my developer apple ID and there it works fine. Afaik the settings regarding 2FA are the same. Resetting the simulator didn't solve it also.


Any ideas?

Replies

Did you run the simulator first, and log in to iCloud there before running that app?

In 2020 this problem probably has to do with all the jiggering of Provisioning Profiles (whatever they are) Apple has recently done but didn't inform anyone.


1) Go to developer account, sign in, and sign the new thing they want signed

2). then follow this....


To fix this, you need to transfer the Provisioning Profile's Certificate to YOUR own certificate. In developer.apple.com, login to your developer account. Then, in the Edit iOS Provisioning Profiles page in Certificates section, select the certificate you are using for your XCode. Then click Generate button.


then you'll still have problems, but will be farther along.

> this problem probably has to do with all the jiggering of Provisioning Profiles (whatever they are) Apple has recently done


If by 'recently' you mean in the almost three years since this thread was touched, sure, recent. But hey, whatever works 😉

I just went through this today 7/17/2020 to setup an AppleID for ApplePay testing. Not only did I need an available (never used email address), but also and never used AppleID. Created a new one, used the new test email address, went through the 2-step verification when I signed in. The key here is that you THEN have to from a browser sign into iCloud.com with the new test user account AppleID and password and ACCEPT the terms. Once that's setup, then go back to sim and it should work. To me it was signing into iCloud.com that was the magic here. -Kevin
  • This is the correct answer. Accept the iCloud terms.

Add a Comment
I searched several days for this question. I cannot sign in with Icloud in simulator. My login and password is correct, 2fa is enabled, sms is coming and all good, but Apple Sign in dont work in simulator.

After searching I found little comment on stackoverflow
//apple.stackexchange.com/questions/321365/does-ios-simulator-in-xcode-allow-appleid-sign-in

So first you need go to icloud.com and .... login, and accept f@@@ terms (facepalm)

//joxi.ru/v297BpqHZbZgMr

After this you Apple Sign in will work in simulator


@carsak's answer fixes the problem, just have to login to icloud.com and agree with the terms then can log in inside iOS simulator...

Apple should do better.

Add a Comment

HUMANCENTiPAD South Park episode (season 15, episode 1)

I logged into my icloud from my desktop as well as the simulator but do not see any terms to accept. But still not able to login in simulator. When I give the wrong password it gives an error. but when I give the right password it keeps rotating indefinitely. Anyone else facing this issue?

  • This happens to me as well. With a correct password, the loader keeps spinning forever... Did you figure this out?

  • I am getting the same issue as well on my simulator as well. Please do update if this is solved.

  • Same thing happening to me

Same issue for me, spinner keep on the screen

  • After 4 years, still nothing with 15.2 and XCode 13.

Add a Comment

Get the same issue - did the Icloud login and just see the spinner. So stupid

For me, this issue was solved by using iOS 13.0 (download iPhone 8 simulator from XCode)