Xcode does not recognize iphone

Xcode 9.4.1 on MacOS 10.13.6 does not recognize iphone (iOS 11.4.1), hence "No devices connected to 'My Mac'".

Even Window -> Devices and Simulators, there are no devices.

But the iphone device is recognized on USB device list.

Could you suggest how I can fix this problem or what I did wrong?

Also, I have noticed that the system report of MacOS says the version of the iOS on the USB is 7.0.2.

But the iOS version is iOS 11.4.1. Is this normal?


Does iTunes see it?

Has it worked w/Xcode in the past?

Are you using an Apple branded USB cable, connected directly to your mac?

Seen this SO thread?


This worked in my case. Xcode13.0 & macOS 11.6

Quit XCode
Disconnect device
In your terminal sudo launchctl stop com.apple.usbmuxd
Relaunch Xcode
Connect device


I started getting this issue all of a sudden now and couldnt get around. @MSree_1234 solution didnt work for me. I'm on  Xcode13.1 & macOS 11.6

@venkat91 did you find a solution ?

I have the same problem since yesterday.

Check that you have an xcode verison that supports your device. Often if you update the ios version xcode sdk needs to be updated too. Strangley i found that xcode can still be in beta while the ios version is live.

Connect your device directly on mac without HUB or docking station.

Yesterday it stopped working suddenly. I updated Xcode and iOS and it's working again.

I just restart my device. This worked for me!

For me, it was the cable. I tried a different cable, and it worked.

My env

cpu : M1 Pro
os : 13.1(22C65)
xcode : Version 14.2 (14C18)

I resolve this issue. follow me.

  1. turn off xcode
  2. disconnect device
  3. In terminal execute command > sudo pkill usbmuxd 
  4. turn on xcode
  5. connect device

In my case it was easy: I disconnect usb cable from MacBook and then connect it. After this iPhone has showed in Xcode.

None of the things above helped me, but simply disconnecting 'the hub' and reconnecting it to my M1 Macbook Air solved the problem.. Iphone just re-appeared in Xcode, without restarting neither the phone nor the Xcode.

Rebooting of MacBook solved the problem

Xcode does not recognize iphone