Unable to change default email application

I've been trying to change the default email application on my Macbook Pro unsucessfully.


I'm using Outlook 2016 on my Mac and would like to use it for all my email as I use Safari to login to my personal web mail. On Yosemite I would open Mail, go to Preferences and change the Default Email Application in the menu to Outlook. I can do that on El Capitan but as soon as I close preferences and open it again the setting is back to Mail.


On older versions of Outlook you could open the app and go to preferences and check a box there to set it as the default mail app but that setting seems to have been removed.


Has anyone else experienced this?

Post not yet marked as solved Up vote post of Puntoboy Down vote post of Puntoboy
69k views

Answers

Hi Puntoboy,


Normally, your change to default email client is saved by LaunchServices, but that database can become corrupted. You can reset the database with the following command in Terminal (copy-paste the whole thing):


/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -all local,system,user


OS X will have to re-learn your preferred non-default apps for opening different types of files again, but it may fix the issue.

Let me know if it does...


Max.

Same issue here, on Dev Beta 8. Even though it is a relatively clean install, Max108's suggestion *did* fix my problem. Thanks!

Thanks for the feedback JoeJoe 🙂

Hi Puntoboy,


Did the above fix not work for you? It would be useful to know...


Max.

Thanks for this!!! Worked perfectly! 🙂

Bang! I was stuck with outlook as default but after your advised terminal solution. It worked!

Thanks. It worked for OSX 10.11.1 (15B17c) and Outlook 2016 (15.13.1).

Got the same issue and fixed it for me. It worked for OSX 10.11.1 (15A278b) and Outlook 2016 (15.15) and Airmail2 (2.5.2 (332))

Have been using this fix over the past 5 years or so, however, doesn't seem to work for Catalina. Anyone know how to fix this same issue in latest MacOS X Catalina? Impossible to change default mail client from Mail to Outlook: just jumps straight back to Mail immediately.

UPDATE: seems a computer restart is required after applying fix in Catalina: at least worked on one example: will update this after further testing.