Launchscreen storyboard doesn't display image

For the new iOS 9 splitscreen feature, I added a Launchscreen storyboard which displays an image located in an asset catalogue. When editing the storyboard the images is properly displayed in Interface Builder, the same goes for devices running iOS 8 or the iOS 9 simulators. However, running the App on a device with iOS 9 GM, the image is now displayed. The storyboard itself is displayed, just the image is missing. Any idea what the problem here is or if I could debug this any further? I don't see any error messages in the build logs.

Post marked as unsolved Up vote post of dlinsin Down vote post of dlinsin
39k views

14 Replies

Taking the images out of the asset catalog fixed the problem for me. I just added the @1x, @2x, and @3x image used on my launch screen to the project the old way and it seems to be working fine. Trying to confirm it through TestFlight now, but iTunes Connect isn't behaving at the moment.

Changing the name from "logo3.png" to "logo3" it suddenly worked!


You saved my day!

[Copy of reply posted to Launch Storyboard not showing image when project builds to device.]

I don't know if this will help anyone. I was having the same problem. I had several images on my launch screen that stopped showing up.

I did three things (the first two on their own didn't do it, but may have assisted the third which did work)

1) Copied all of the images to the root directory (same location as xcode puts the images)

2) Created a folder in Images.xcassets and put the images in there.

3) The images in the launchScreen.xib were originally called imageName.png. This was changed to just imageName (remove the file extension.

After the third thing the images appeared. I don't know if either of the first two steps are required, but hopefully it will help someone.

I had the same problem, and was able to fix it by changing image property of imageView to other and back.

Thanks for sharing...!


It worked for me after changing image property of my launch image using Preview app:

[ Tools --> Assign Profile... --> ColorSync Profile: <<To something else + Save + change it back to original profile + Save>> ]


Hope this helps someone...!


Cheers 🙂

Seems you need Image Propety in images. I came over this when I compared projects, and one of my projects did not have this problem and this had Image Property added, and the one with black box did not. Added Image Property and it works fine.

It seems that iOS9 likes images better with image property. You can add one with Preview. [Tools -> Add Profile]

Same thing happens to me. And I don't know what to do with it.

My situation is like this:


1. The image which I want to use inside LaunchScreen but won't be appearing is just displayed fine after App is running. So I don't think it is a image file's problem.

2. When I switched launch image to other images which I have no intentions to use as the purpose, it works as intended (popped up while launching). So it is not a Image View's problem eigther.

3. Simulator shows image, problem occured when I tried with real device(iOS9GM 5s).


I tried to replace files and delete / remove caches files, but no luck.

This still exists in iOS 9.0.1, as I ran into it today. None of the suggestions above seemed to work.


Even deleting the app and re-installing from XCode doesn't work. However, changing the bundle ID does work. With no other changes, the existing bundle ID shows no images, but the new bundle ID shows them all correctly. I'm doing that as a temporary work-around, since a previous post in this thread suggests that installing the builds via TestFlight doesn't encounter the problem.


This was the only post I could find online about the problem, so I thought I should reply here about it. Since there's a bug ID above already, I won't bother sending in a duplicate report.

I'm having the same issue.


1. LaunchScreen with a UIImageView.

2. Image is displayed as intended in Simulator.

3. Image is not displayed on real device running iOS 9 GM.


Here is the strange thing...I created a super simple test project to just try testing using a UIImageView inside a LaunchScreen. Created a new single view project in Xcode 7 GM. Added some quick test images to the LaunchScreen storyboard, and it worked on both simulator and on real devices running iOS 9 GM (the UIImageView in the LaunchScreen is displayed).


Looking through the device logs, I noticed the following error messages when running the app where the images didn't load in the LaunchScreen:


splashboardd[169] <Warning>: Could not load the "Launch" image referenced from a nib in the bundle with identifier...

<Notice>: 0x40081000 -[MIClientConnection snapshotWKAppInCompanionAppID:toURL:options:completion:]: Snapshot requested for...


Any suggestions on how to resolve this?

I have this exact issue. Has anyone filed a bug report?

I did a few minutes ago.


22665923

This is strange, after leaving it roughly a day and coming back, the image is now showing perfectly fine...

I have been having this issue on and off with iOS9GM, I find sometimes the images will appear sometimes they won't. Has anyone found a solution or at least a workaround for this bug yet?

Apprarently, it worked fine on the device when tested with TestFlight.

So it won't be a problem with the release build, I guess?