No matching provisioning profiles found

Hi,

i can't fix this error: "No matching provisioning profiles found for "..." None of the valid provisioning profiles allowed the specified entitlements: application-identifier, beta-reports-active, keychain-access-groups.


I tried regenerating profiles and other suggestions from stackoverflow but it still doesn't work.

I use the latest xcode version from the app store 7.2.

Platform iOS

Post not yet marked as solved Up vote post of MrMatthias Down vote post of MrMatthias
22k views

Answers

thats what happen to me i don't have any idea how to sole it

Did you find an anwser? As I think I have the same problem with an app that uses the keychain.

I got same error on Xcode 8, can any one please help me?

Same problem in Xcode 7.3.1.. I cant solve it 😟

I also have this error in Xcode 8. I haven't been able to find any working solutions for this online (I tried SO suggestions as well, though no one seemed to have precisely the same problem). Did anyone ever figure this out? If not, could this be a bug?

Update: I finally figured this out. Well, sort of. Here are the steps I took:


1. I deleted all of the provisioning profiles, but this did not seem to help.

2. I checked that the provisioning profiles I eventually used had the correct entitlements using 'security cms -D -i "Payload/YourApp.app/embedded.mobileprovision"' on the command line (see https://developer.apple.com/library/content/qa/qa1798/_index.html for more info). At this point, I knew the provisioning profile was fine, but the archive still gave the same validation errors.

3. Then, in Target -> General -> Signing, I tried manually setting the Provisioning Profiles (turning off 'Automatically manage signing' and set them myself). At this point I discovered that somewhere the Product Bundle Identifier had been set wrong in Xcode, which caused a mismatch with my Provisioning Profile. I finally found the wrong Product Bundle Identifier in Target -> Build Settings -> Product Bundle Identifier.

4. Once I fixed this, it correctly validated. I'm not sure if reinstalling the provisioning profiles helped at all (which explains my earlier 'Well, sort of'), but I'm sure fixing the Product Bundle Identifier helped.


I hope this helps someone else, and I sincerely hope Apple improves their error messages to make this sort of issue easier to debug.

Post not yet marked as solved Up vote reply of ab72 Down vote reply of ab72

It is working for me too now, since the update to the latest Xcode, with seting code signing to automatic (as ab72 points out) and also in 'build settings' set all 'provisioning profile' optins to automatic.

This was my problem as well.......would have never found it. Thank-you

Doing the 3rd step helpmed me.

Thanks for the help.

Kudos ab72!!!!


I wasted hours trying to fix this looking around for answers, trying them, fail, repeat.


I think the magical piece was removing the automaticly manage signing and doing it myself and telling xcode to download it during that process.


Again, thank you a ton!!!!

Resurrecting an old thread here, but thanks ab72, you fixed the problem I had just spent literally *hours* trying to solve. I was trying to upload an app with an iMessage extension to the app store, getting this exact error.


Somehow the Product Bundle Identifier in Target -> Build Settings -> Product Bundle Identifier was not correctly set for all targets, even though it was set corrrectly in the "General" tab for all targets. Another weird Xcode-ism.

.

Creating an account just to add my 2 cents: I actually had to go to "Users and Access" and change my permission to Admin - very odd since I never messed with those settings since first configuring everything.