.XIP File Extension?

I hadn't ever seen this appear on any platform before the new xcode 8 beta download. macOS 11 uncompresses it fine, but I can't seem to find any info as to how this might different from .ZIP.


There is very, very old .XIP file extestion from an early 90s HP 95LX with MS-DOS 3.3.


Not a big deal. Just curious.

Post not yet marked as solved Up vote post of Verkkon Down vote post of Verkkon
24k views

Replies

From what I've read, it appears to be a ZIP archive, but it verifies the file with Apple servers.

And it took forever to verify yesterday too...probably 20 minutes. I was just about to force quit it when it completed and I was able to continue.

Thanks for the prompt reply, Ross. If it verifies with Apple's servers as a requirement, then you wouldn't be able to install while disconnected from the network. It might not affect many, but it will be annoying for those that it does affect, assuming that's the case.

Someone posted this that will cause Archive Utility's check to bypass

In Terminal:

xattr -d com.apple.quarantine Xcode_8_beta.xip

I've renamed in .zip and uncompressed fine

its actually an xar archive


its like tar but it stores the Table of Contents at the top of the file.


Easiest way to unarchive is


xar -xf Xcode_8_beta.xip

Over on StackOverflow, I explained how .xip can be expanded from the command line without Archive Utility, always verify signature to avoid malicious Xcode builds!

also unpacks fine with The Unarchiver.app

xip is a xar archive but has the ability to be digitally signed. With the App Translocation feature and removal of the GUI Gatekeeper option to allow unsigned apps I'm guessing we'll be seeing more of that in place of .zip for developers that distribute their software via archives instead of .dmgs.


You can access the contents by running the following:


xar -x -f Archive.xip

ditto -x Content .

lol, this worked. wow

I upgrage my iPhone to 9.3.2 , then I can't use it to develop, as I don't have a SDK for it.

You can find it at Xcode/contents/developer/platform/iphoneOs.platform/devicesupport,

if you have a directory named "9.3.2(13F69)", please mail it to 28181306@qq.com

many thanks!

me@my-mac ~ $ ditto -x Content .

ditto: cpio read error: bad file format


This is with XCode 8, I'm on 10.11.6

This does not work with Xcode 8.

I couldn't get real command line tools working either. The only thing that seemed to actually unarchive a XIP was the Archive Utility so I wrote an Apple Script to handle it and exit when it was done running: https://gist.github.com/JScott/5be1c2770f2134b22a67d417fd91c895


You'll have to make the script binary through Script Editor and then call it something like:

osascript unxip.scpt /tmp/Xcode_8.xip


It should open the Archive Utility where you can visually watch the progress.