AX88179 not working

I have a AX88179 GigE to USB3 adapter. It isn't recognized under Sierra. I am guessing they change the driver signing setup again, like they did for 10.11.4. Anyone else have this issue?

Bug reporter seems to be down, I can't report it there.


Same here, any luck on your side?

I always install these driver not the one came with my Inateck.;71;112 and it work with Sierra.

I can confirm. I am having same issue here. No luck getting it working 😟

Same issue here.

I still have the issue. I have an open bug with Apple.

This fixed it for me. I upgraded to Sierra and my USB 3.0 + Gigabit device stopped working. I tried reinstalling the drivers from Unitek with no luck. Once I installed the drivers from;71;112 then it worked. I haven't run diagnostics to see if it is getting appropriate speeds or anything of that nature, but it seems fine so far.

I have the same issue

I have the same issue

kest is not loading:

sudo kextload -b com.asix.driver.ax88179-178a


com.asix.driver.ax88179-178a failed to load - (libkern/kext) not loadable (reason unspecified); check the system/kernel logs for errors or try kextutil(8).

Appears to be a question of signing the kernel extension:

sudo kextutil -b com.asix.driver.ax99179-178a

Can't find extension with identifier com.asix.driver.ax99179-178a.

Johns-MacBook-Pro:~ jeckman$ sudo kextutil -b com.asix.driver.ax88179-178a

Untrusted kexts are not allowed

ERROR: invalid signature for, will not load

Signature failure in dependencies for kext load request.

Anyone know how to get Sierra to run unsigned kexts?

For whatever it's worth, this worked for me:

Removing the AppleRTL815* from /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/ and rebooting

I am having the same problem.


macOS 10.2.2 (16C67)

Model Name: MacBook Air

Model Identifier: MacBookAir6,2

Processor Name: Intel Core i5

Processor Speed: 1.3 GHz

Update driver per recommendations in this thread. So now on startup the connection doesn't work, but if I unplug and replug the USB connect it works fine.

I've used the Asix driver consistently. Installing the latest driver resolved my issue. Thanks.