Does macOS sierra support any version of mysql?

Yesterday I decided to install the latest version of mySQL to macOS Sierra Developer Beta, and I had a bad time figuring out what was happening with my freshly installed macOS in my MBP. The installation never finished ( left running overnight ), and got until 98% where I had to hard restart my computer.

Then when the system loaded, mySQL was installed, but now my MBP was taking forever to shutdown / restart. ( 8 - 15 minutes )

I spent a day trying to figure out the cause of that issue, and then I realised that the problem was a file on the LaunchDaemons named "". As soon as I removed this file, my system went back to normal 4 - 5 second system shutdown.

Does anybody has been able to install mysql on a clean install of macOS sierra without the issue I just mentioned?


MySQL 5.6.31 just works for me. I haven't tested it extensively though since I'm more interested in why MySQL 5.7 *doesn't* work.

With MySQL 5.7.13, mysqld hangs on exit. The installation does not finish because when mysqld is invoked to create the data directory, it never exits. It seems as though the installation *is* complete at this point, but because the installer fails, the root password has to be recovered as documented in the MySQL reference manual, or the data directory has to be removed and re-created manually, which will allow the user to see the generated password.

The hang on shutdown is probably the same issue. The default installation includes the launchd script you found that is responsible for starting mysqld at boot. Removing it fixes your problem, but it's also possible to simply turn autostart off in the MySQL preference pane that's part of the installation.

The mysqld-debug executable does not seem to hang, so if MySQl 5.7 is required for testing purposes it might be possible to replace /usr/local/mysql/mysqld with mysqld-debug in the same location as a temporary workaround.


I had the same problem and fixed It upgrading my current installed version (5.7.10) to version 5.7.15.

I used this guide for upgrading without losing database information:


HUGE! Thank you 🙂

I am extremely frustrated with this MySql issue. Never have I had so many problems. All seems to be with this MacOs Sierra. I have tried using MAMP and MySql works fine BUT only locally. I can not access it remotely at all, no matter what I do. I have tried installing MySql natively and the System settings says the server is running, but there is no access to it, no command line no nothing. This is so bad that I will be forced to build a linux server just to continue development. I have been developing for years. The differnce is that I bought a new iMac that came with Sierra. So my original Dev machine is gone. Perfect. Why would MAC all of a sudden stop support for MySql? Unless it is a fight between Mac and Oracle?

Hello Xilobyte,

There is no fight that I am aware of. Apple and Oracle are in different markets and are not competitors in any aspect. As far as I know, they are each big customers of the other.

I don't know if macOS is really the right platform for this kind of activity anymore. If you really, really want to run a service locally like this, I recommend Docker instead. Then you can run MySQL under Linux right on your Mac. Docker is more friendly to local CPU and disk resources than a VM.

Taking it a bit further, you might want to consider cloud services. They have definitely reached commodity level now. Prices for services on the research and development scale are very reasonable, if not flat-out free. The cloud providers plan to make money when you deploy. Unless you plan on doing development on a week-long train trip without internet, there is little reason to have local services anymore.