Xcode 12 Taking a Long Time to Expand

Hello! I am installing Xcode 12 on an external solid state drive due to low storage on the main hard drive on my Mac. However, I cannot figure out how to get it to finish the unzipping process. As of now, it has been unzipping for the past two hours. Is this supposed to happen? Does anyone have suggestions on how to get it to finish the unzipping process, so I can use it? Thanks!
Post not yet marked as solved Up vote post of tommyreid Down vote post of tommyreid
14k views
  • I download Xcode_12.5.1.xip and extract it using xip. The extraction takes forever, so I take a look at the extracted files, and it grows over than 96GB from the original 11GB. So I stopped the extraction. Who knows how space will it consume after the full extraction. (76GB is from folder Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Library/Developer/CoreSimulator) https://i.imgur.com/yTSk9PS.png https://i.imgur.com/yQyVGTe.png

    Why do Apple expect that we all have enough space to store the fat boy Xcode? Does anyone knows how to extract subset of files from a xip?

Add a Comment

Replies

same issue bro since 2 days I try to install but still not install. Now a days My whole day task is installing Xcode. ;)

Running Time Activity -> imgur.com/a/BZwh6i4
Same here! Went for my lunch and after 1 hour the expanding progress is a little over 60%.
Same here freezed unzip process and also exhausted disk space. Even worst part here in this forum - no one from official Apple team responded yet (3 months and counting.)
Same here!!!
Where did you download from ? Appstore ?

If so, try download from https://developer.apple.com/download/more/
Same here. I tried to install in macOS Sierra V 10.12.6 Still couldn't install it. Taking too much time to expand and stopped in the middle of the process. I, too, need a solution
Same here, Trying to install in macOS Catalina :(
I downloaded Xcode on my external drive and need to extract xip file with command line.

cd /Applications
xip -x /Volumes/mydrive/Xcode_12.5.xip

Same here as well. Anyone got any solution so far on this?

Same here for XCode 13.

I copied to a the external drive and ran :

time xip -x Xcode_13_beta3.xip

After 24 minutes it spits out a bunch of errors:

54: Error: failed to write 8992 bytes to /var/folders/lf/khb1n07j4nvf8tgybttqs81m0000gn/T/C063E34F-1D18-446A-8E4F-34E3377C56A7//Xcode-beta.app/Contents/SharedFrameworks/GameToolsFoundation.framework/Versions/A/Resources/animateWithTexture_48.tiff(9) at 0: No space left on device

man xip says:

--expand <input-file> Expands the archive into the current working directory. This option cannot be used with any other arguments.

Oh really? /var/folders/ is not the current working directory.

Here is a tip. First install it on your Mac's internal SSD and then directly move it to your external SSD. In this way, you'll have it installed on your external SSD, and would be a little more faster.

  • Already using SSD and still excruciatingly slow...... and I'm on a new MacBook Pro with 32Gb..

Add a Comment

Same here too. Trying to install the current Xcode 13 beta . I am on Big Sur 11.6, first tried with double click ( it did not work ) and now through terminal. So far 2 hours and it is stuck on the very first line that is says: " xip: signing certificate was "Software Update" (validation not attempted)" I dont know what to make of it .... going to leave it like this for the night and check it in the morning. And yes, my hard drive has 1.2 TB free space so this not the reason. Any faster and working solution would be highly appreciated.

Add a Comment

Any working solution so far?

Me also had same problem. While I'm writing this (answer) my unzip process just already finished, it takes about almost 3 hours. Almost cancel the process, thank god still have mood to wait. Huhhhh...

Well, this worked for me:

  1. Download XCode from https://developer.apple.com/download/all/
  2. Transfer the .xip file to your external SSD.
  3. Extract/Unzip the Xcode from .xip file there.
  4. After extracting, transfer the XCode into your Applications Folder.

P.S I successfully installed XCode 13.1 using the above process on my MBA.

P.P.S I had around 37 GB left on my mac (before installing) and used a 2 TB SSD