Clock and Weather Widget in iOS 14 beta 3 issues

Having issues with the Clock and Weather Widget in iOS 14 beta 3. The Clock will not tell the correct time and the Weather widget is not showing anything.
Post not yet marked as solved Up vote post of gamebroz Down vote post of gamebroz
4.2k views

Answers

The same is happening to me
Same here
Would I need to download the applications in order to have the new widget format?
Same here!
Clock is fixed when choose another city and go back to yours after. But i guess this is temporary solution
Weather doesn't work on Weather Widget or Smart Stack, does not display anything, just a black screen
Clock is stuck on Cupertino like everyone else. I have tried changing it by changing the time in the clock app but nothing

thanks
Same here weather widget went blank from prior beta and is not on the + list nor does it find it under search. Plus is there a an option to resize a widget with out removing it and then adding it back?
When changing clock widget to local time, the clock does not keep time. Slowly becomes inaccurate overtime.
This was happening to me as well. To fix it, I dragged the Weather app (not the widget) out of a group of apps, then I opened the Weather App. At that point, the Weather widget started working again and I saw it in the list of widgets to add when editing widgets.

I’m not sure if moving the App or opening it is what fixed the issues. It continued to work when I put the weather app back where it was originally.
Same here. The weather worked for a min last night and then today it is stuck on last nights forecast. The clock is working but will not update time. The other app I see not working is the news one. It stays on the same story even when they have updated.
Hey, it seems that the weather thing has been fixed for me, I can now find it and use it now, I think it was just a bug as I was confused as well, hope this helps, also the clock widget is fixed as well.
Mine only shows weather for Cupertino CA on the display and when I click it goes to my current location in the app
Reset Location & Privacy data.

Make sure the apps are turned on for Background App Refresh.

Fixed it for me.
The same is happening to me...
Same here already reported on IOS14 iPhone 6s but now also happening on IPadOS14 on original iPad Pro 9.7”. Clock runs slow. For those that don’t know you can change the time zone location independently of the device time zone by simply pressing and holding the widget and selecting ‘Edit Widget’. You can temporarily fix the clock by selecting another time zone city then changing to back again.
Post not yet marked as solved Up vote reply of 4c21 Down vote reply of 4c21