iOS 10 OTA Distribution sometimes fail and bug out the device, the only solution is a factory reset

Hello,


When I go to our itms-link I have to enter the https authentication details 3 times when downloading, 1 for the .ipa file and 1 time for each of the icons, i figured. (Is this expected behavior?) However, if I some time during the authentication back out of Safari the installation will fail, and a grey icon of the app saying either the name of the app or "Waiting" will appear, and it is not removable, in any way. I then get spammed with "Authentication Required" messages telling me to fill in authentication info for the https site, doing this will result in nothing, but after a while the same dialog will pop up again. Restarting the device and doing resetting settings do not help. I had to factory reset it and then it worked again. Now this is happening to me again. Has anyone else experienced the same issue?


Sorry for a maybe confusing and not so well structured post. Thanks.

Replies

I have same issue with downloading the .ipa file using https basic authentication on iOS 10.0.2. I cannot remove grey icon and "Authentication Required" messages come up again and again.

I have a couple devices stuck in the authentication-from-****-loop and it's very frustrating. Two things I've been able to do to stop the prompting madness.

  1. Install the app from XCODE directly
  2. Delete the app icon…this one takes some timing as it looks like the app store background process is crashing (see the iOS logs on your device to verify with the app store profile installed). Timing is the prompt reappears after about 6-7 seconds, the background process restarts after ~5 seconds, so you have a ~1 second window to delete the icon.
  3. Kill app store, this sometimes works and sometimes doesn't

Both of these are temporary fixes, and the prompting starts again when I try another ad hoc download.

Anyone find a solution to this without a factory restore? I’ve run into this in the past and was able to stop the madness, but I haven’t found a solution with IOS 10.0.2.

I did issue a bug report to Apple, and encourage you to do the same.

I am having the same issue, this is so annoying.

I am also experiencing this issue. Super frustrating as it gets stuck in an Authentication Require loop ... going to fill out a bug report as well. If anyone has had any luck tracking this down please let us know.

This is one of the worst bugs I've ever seen. Until you manage to figure out how to remove it, the phone is practically useless.


We've also noticed this issue only with iphone 6, and only on re-install. In addition, removing the basic auth and even using a different URL does nothing, and causes it to still attempt to hit the old URL...

I have the exact same issue (iPad Air 2 with iOS 10.1.1). The authentication dialog keeps on showing again and again. Looking at the logs of the web server it seems that the HTTP requests sent are invalid. It looks like they are missing the WWW-Authenticate header. The http protocol specification states that if the server responds with 401, the http request should be re-sent but with the header. However, that header does not make it to the server. Looking at the device logs there seems to be a lot of crashes relayed to the "appstored" process.


Also have a look at this thread where they suggest some extra steps such as making sure that web server has https with TLS 1.2 and Forward Secrecy. However I have the proper SSL configuration and it still doesn't work.


https://forums.developer.apple.com/thread/63865

Apple have reliesed a "silent" iOS update which is still versioned 10.1.1 but has a build ID of 14B150 (original iOS has a build id of 14B100). The new update is only visible in iTunes (you won't see it in the settings app).


I have just done two tests on 14B150 and the problem seems to be fixed now for me.

Hi Alex,


Thanks for posting the information. I was hoping this would solve the same issue that I am seeing, however one of my testers downloaded the update but the issue still remains.


Did you do anything else besides apply the update?


Mark.

Hi everyone,


I am facing the same issue, using TLS 1.2, iPad mini 4 running iOs 10.2 beta 5. It is very frustating.

Hope Apple throws some light on "what needs to be done".


Kind regards,

Julian

Hello,

Any final solution for this stuck?

Apple just closed my bug as a duplicate after a few months of waiting, still no update on the atuall issue.

My company just encounted this issue yesterday. Web server also support TLS1.2. iOS version 10.2.1 build ID 14D27.

Quick check on this -- because our company gave up on OTA installs under iOS 10 since it was completely unreliable, and in the worst case, required a user to reset their device. Which really is not acceptable.


Has iOS 11 resolved this issue? It was pretty sporadic for us under iOS 10 so a successful test on my side doesn't build my confidence to a level where I'd start using OTA enterprise deployment again.


How have people found iOS 11 OTA enterprise deployment? Reliable? Loop bug fixed?


Thanks!


\marc