Xcode12 build error. The linked framework 'Pods_projectA.framework'is missing one or more architectures required by this target: arm64

This morning, the Xcode, which had been doing well, has been updated to version 12, and it has not been built since the error 'The linked framework 'Pods_CafeHome.framework'is missing one or more architectures required by this target: arm64' occurred.

I updated Cocoa pod.
I removed all about pod and installed again.
but i could not resolve

Replies

I'm having the same problem after upgrading to Xcode 12
Adding "arm64" to Project -> Build Settings -> Excluded Architecture fixed the issue for me
  • ESO YA LO COMENTARON, PARA QUE MIERDA PUBLICAS LA MISMA RESPUESTA? QUE TANTAS GANAS DE FIGURAR TENES PEDAZO DE IDIOTA

Add a Comment
I'm having the same problem with a project of mine after updating to Xcode 12, except the "embedded framework" here is one of my own from a subproject.

Framework has Standard architectures set in build settings...trying to run on the iOS simulator, the app won't build. If I switch to an iOS device Build succeeds.
This issue has been fixed for me after adding "arm64" to Project -> Build Settings -> Excluded Architecture for varients.
  • ???????????????? PARA COMENTAR MIERDA QUE NO FUNCIONE AHORRATE EL COMENTARIO, TU AYUDA ES LA PEOR MIERDA

Add a Comment
same here, the proposed solution seems to resolve this, but can we get some insight why is this happening?
I also ran into this problem when running my project on the simulator - I forgot I had switched over to the "Release" build configuration a couple days before, and switching back to "Debug" fixed the issue.
Had the same problem, but solved.
  1. You can try to add arm64 to the Build Settings -> Architectures -> Excluded Architectures for Any iOS Simulator SDK. It helps many of devs, but for me it didn't work.

  2. You can Clean Build Folder (⇧ + ⌘ + K), clean DerivedData directory, CocoaPods caches, and restart macOS, Xcode and Simulator. This solution works for me.

  • Thank you! The second is works for me

  • The second one helps me. Thanks!

  • Your solution and clear description HELPED – THANK YOU VERY MUCH!!!

Add a Comment
I've encountered this issue too.

Try to add $(ARCHS_STANDARD) to VALID_ARCHS in Build Settings.

Steps:
Build Settings -> User-Defined -> VALID_ARCHS ->
add $(ARCHS_STANDARD)

heres more info in stackoverflow.

Environment: Xcode 12.2 beta3
Go to project -> build settings. In Architectures -> Excluded architectures add for all debug and release fields field "Any iOS simulator SDK" with value "arm64" (without quotes). Do the same for pods architectures. After that clean project (shift - cmd - k) and run the project.
  • HIJO DE PUTA, ES EL TERCER COMENTARIO POSTEANDO LO MISMO, MOGOLICO, NO TE DAS CUENTA QUE YA 2 PUBLICARON LO MISMO, HIJO DE PUTA, TU AYUDA DE MIERDA YA FUE PUBLICA, APORTA ALGO NUEVO MOGOLICO, DESEREBRADO MENTAL

Add a Comment
I just got the same error message while building an old (Xcode 11) project in Xcode 12. Cleaning the project with "shift - cmd - k" (as suggested by vladimir1983) fixed it, no need to change any settings or restart Xcode/the Mac.

Be sure to open .xcworkspace file, set arm64 to 'PROJECT' in Project and Pods not 'TARGETS'.

Running Xcode in rosetta helped me.

This happens every time I switch processor architecture by testing apps on muliple devices. Going from arm64 to arm7, newer to older iPhone model and back. In this case the solution is to clean the build folder.

In the beginning you have to be you must check "open using rosetta" for rosetta 1- open finder 2- go to Application 3- find xcode 4- right clic 5- info 6- check "open using rosetta" then clear DerivedData 1- open terminal 2- rm -rf ~/Library/Developer/Xcode/DerivedData 3- hit return in your keyboard close xcode the open it or restart your mac i think you now better than and the project run good

I believe I had my project set up for armv7 development and I opened up Xcode using Rosetta on accident. I dechecked the box, and restarted Xcode.

This solved my problem without adding any entries into the excluded build arches.

Monterey / Apple Silicon