SMB shares broken

I am running Big Sur beta 10. after upgrading my system to Big Sur, I lost the ability to connect to existing smb shares on both my windows server and linux RPI machines.

Is there a work-around or an ETA when this might be restored?

I have tried the usual "Connect to a server" method and and the cli smb mount method.
Thanks
Post not yet marked as solved Up vote post of JKing42 Down vote post of JKing42
4.5k views

Answers

Broken here too on beta 10.
Code Block
/usr/bin/kmutil load -p /System/Library/Extensions/smbfs.kext

and
Code Block
sudo kextload /System/Library/Extensions/smbfs.kext

do not fix it for me.

The error: There was a problem connecting to the server.

From the console:
Code Block
error 15:22:25.772855-0700 sharingd SDNetworkResolver: handleMountCallBack returned -50
error 15:22:25.778284-0700 kernel Sandbox: bird(341) deny(1) file-read-data /Users/xxxxxx


Try the following:

sudo /usr/libexec/configureLocalKDC

It has fixed file sharing for me in the betas. Someone else posted it before and it's referenced as a fix for a similar issue in a security update for macOS 10.13:

https://support.apple.com/en-us/HT208317
No luck Scimon , it behaves as before. Thanks though...
It's working fine with the new beta.
Hi

I have same problem
MacOS Big Sur beta 10 (20A5395g)
smbfs.kext driver already loaded.

error report that:
kernel smb2sessionmaxread: Limit max read quantum size to maxmsgsize <1048576>

Any workaround?, thanks.

This has been broken for me on three separate occasions. The kextload trick fixed it the first time, but these last two times (last on RC2) I was seeing this in Console:

Code Block
realpath for /private/var/db/mds/messages/501/se_SecurityMessages failed: 2


And these commands fixed it:

Code Block
sudo mkdir -p /private/var/db/mds/messages/501/se_SecurityMessages
sudo chown {my username} /private/var/db/mds/messages/501/se_SecurityMessages


I have no idea why that folder was missing from my startup disk, nor why mds wouldn't automatically recreate it. The moment I ran that second command, though, the SMB share mounted immediately.
The SMB share works for a few hours and then after that, you can see the shared Mac but none of the folders show up. If I toggle the File Sharing off and on, the shares come back but then a few hours later, they stop working again. Does anyone have a fix for this with Big Sur? Everything worked fine in Catalina. This is from a clean install of Big Sur too.
请尝试以下操作:

sudo / usr / libexec / configureLocalKDC

它在Beta中为我提供了固定的文件共享。之前有人将其发布,并且在macOS 10.13的安全更新中被引用为针对类似问题的修复程序:https :

//support.apple.com/zh-cn/HT208317


The SMB shared file has been executed at the terminal but cannot be accessed using a linked server
I just encountered this issue on a fresh format-and-install (not an upgrade) of the public release of 11.1 on a round Mac Pro; when I'd try to connect to either smb:// or afp:// network shares, it would first show the warning dialog asking me if I wanted to connect, then when I clicked Continue, the "Connecting" dialog would sit there forever with the KITT/Cylon animation, never prompting for credentials or connecting.

I tried the kextload to no avail.

@bombich nailed the solution in this very thread, which is apparently still an issue in 11.1, wow.
Just found the same problem, I was getting permission denied when I tried to connect from my laptop to my iMac shared folders

My setup:
iMac 2020 27", Big Sur 11.1
Macbook Air 2015, Big Sur 11.1

I entered those two commands from this thread
/usr/bin/kmutil load -p /System/Library/Extensions/smbfs.kext
sudo kextload /System/Library/Extensions/smbfs.kext

And now it's working and can connect from my mac air to the sharing folders in my iMac.

Thank you for the solution.
I am on a MacBook Pro 2018 running Big Sur 11.2.1. I just updated it and have lost the ability for the other Macs in the house to connect to me. I am the only one running Big Sur. I have copied and pasted the commands given and it isn't working.

Loading kext, running chown on se_SecurityMessages did not fix mount_smbfs for me on Big Sur 11.6. Always unknown error.

  • just upgraded to Big Sur 11.6 on both laptop and mac mini. SMP not working. I've tried all of the above and none of it seems to work. Is this still an on-going issue with Big Sur?

Add a Comment