Getting a "certificate is not trusted" error for iOS Distribution Certificate

To support an older version of an iOS app, I needed to install Mojave with Xcode 9.

I create a CSR and from there generate an iOS Distribution certificate online, which I download and double click to install in Keychain. However, when viewing in Keychain, it shows in red "iPhone Distribution: CompanyName certificate is not trusted".

I'm not sure what I'm doing wrong as I follow the instructions to the T and have done this in the past with success.

NOTE: I tried this with Sierra as well and got the same issue. It only seems to work on Catalina, which doesn't help me because I need an older version of Xcode.
Post not yet marked as solved Up vote post of johnjardin Down vote post of johnjardin
69k views
  • thanks man - this ate my brains for 3 hours to figure out

Add a Comment

Replies

Apple has updated Developer Relations Intermediate Certificate. Just download the certificate from here and install it. If the it doesn't works have a look on https://developer.apple.com/support/expiration/

God bless you @patelgaurav4u_ios!
  • Thank a lot Patel, very helpful : downloaded, double clicked and certificates turn green 😃

Add a Comment
I LOVE YOU PATEL
You beautiful man
PATEL You the real MVP
Patel you are a legend
THANK YOU PATEL!!!
Patel, thank you so much!
You are an angel, thank you!
Thank you, I was crying for 2 days because of this :v
So much wow Patel, thsnks <3
Thank you, thank you, thank you so much, @patelgaurav4u_ios!!! You really saved my day here, having been stuck for hours wondering why my apps built with my developer account suddenly wouldn't run!
Thank you! I spent hours dealing with this, glad I found this post and solution.
@patelgaurav4u_ios Thank you so much! I joined the Apple forums just to thank you. Worked instantly!
<3
Thanks patel, that helped.
  • Thanks, Patel. That was very helpful; a straightforward fix.

Add a Comment