Xcode 12.5 unable to install app on iOS 14.5 device

I upgraded Xcode to 12.5 and iPhone to 14.5 yesterday.

It works fine on iOS 14.5 simulator and my old version device. But It shows
Code Block
Unable to install "AppName"
when I want to run it on my iOS 14.5 iPhone.

The detail said
Code Block
The code signature version is no longer supported.

I tried cleaning build folder, restarting Xcode and phone, still didn't work. Any ideas?


Post not yet marked as solved Up vote post of BBeing Down vote post of BBeing
6.2k views

Answers

Same problem here
I ran this past DTS’s Tools Guy™ and he confirmed that this isn’t a widespread problem. My best guess is that there’s something about your project that triggers this. So, as a first step, please try creating a new project from one of the built-in templates and running that on your device. Does that work?

Share and Enjoy

Quinn “The Eskimo!” @ Developer Technical Support @ Apple
let myEmail = "eskimo" + "1" + "@" + "apple.com"
Follow this thread: https://developer.apple.com/forums/thread/679182

When I removed the App which on the device add restarted device, it works.