Can't install macOS Monterey beta on M1 external drive

I tried to download the beta and install to external SSD connected to M1 Mac mini. The installation continues until restart. The external drive cannot be used to boot up.

SSD is erased and set to:

  • APFS
  • GUID Partition Map

This strategy has been used in the last few years with Intel MacBook. I wonder if this is a problem with macOS or M1 machine?

Post not yet marked as solved Up vote post of harryworld Down vote post of harryworld
3.7k views
  • Just tried to install on Intel MacBook external drive. Like expectedly it works.

Add a Comment

Answers

Same here, getting: "An error occurred while setting “MacOS 12” as the startup disk: The operation couldn’t be completed. (SDErrorDomain error 108.)" when trying to boot to external drive on M1

Post not yet marked as solved Up vote reply of Uri Down vote reply of Uri
  • same here. running a MacBook Pro 13 M1.. It seems I can boot off my external that was migrated pre M1... but I am unable to select this partition I just installed on the same external SSD

  • Same here. MacBook Air M1.

  • Same here, I can’t test my app on macOS 12 due to this. hope next beta will fix this or some tip will help us make the install possible.

My first attempt was like everyone else. A spare partition of 256GB on thunderbolt drive. So I had good backups and decided to install on Internal m1 Mac mini disk. This erased the installer so in terminal I:

softwareupdate  --fetch-full-installer

which downloaded the installer. The first time I ran it, it errored out. So I ran it again and it installed and boot the new part. This makes me wonder about the deterministic nature of this. So if you run Monterey, you can get an external disk running it.

What finally worked for me was installing the macOS 12 beta from inside the recovery mode:

  1. Download the Monterey installer app onto your internal SSD.
  2. Boot your M1 Mac into recovery mode by shutting it down first and pressing + holding the Touch ID key.
  3. Connect your external drive and format it using Disk Utility; choose APFS as file system.
  4. Disk Utility can also be used to unlock your Mac's internal SSD in case it's File Vault 2 encrypted.
  5. Still within the recovery mode, open Terminal, navigate to the Monterey installer location (probably ~/Downloads on your internal disk)
  6. Start the installation process by executing ./Install macOS 12 Beta.app/Contents/MacOS/InstallAssistant

Note that the installation may take significantly longer, especially towards the end.

Post not yet marked as solved Up vote reply of fedo Down vote reply of fedo

In my case, I tried to install Monterey beta into a volume created in the Big Sur's APFS conainer. https://gyazo.com/2f0275ed0d7b4f120a4d8cce8a854e99

At the time of restarting, it failed (waiting more than few miniutes after quiting visible apps). So I restarted myself. After restarting, Big Sur is booted. I tried to select the Monterey volume as the start up disk (System Preferences -> Startup Disk).

I got an error:

An error occurred while setting “Monterey” as the startup disk: The operation couldn’t be completed. (SDErrorDomain error 108.)

https://gyazo.com/427104df6897d5adc65d3222c2c95dfb

The key (at least for me) was to use a Thunderbolt 3 SSD. After various attempts with a USB-C Samsung T5 I came across some articles (to which I can't like on these forums for some reason... - search for "How to boot an Apple Silicon Mac from an external drive") that pointed out that requirement.

I then ordered a Samsung X5 external Thunderbolt 3 SSD and the installation went and worked fine with that.

  • In my case, when I tried to install Monterey to ssd connected to macbook's own Thunderbolt 3 port, always installed but failed to boot with that, but when I install Monterey to ssd that connected to Belkin hub(or any usb hub?) then it succeed in boot and operate...

    I think, installation detect thunderbolt port and what is connected to thunderbolt port... if ssd that connected to thunderbolt 3 port is not thunderbolt standard device? then it is failed.... but when using usb hub and ssd to it (that's not thunderbolt speed) then Monterey thinks it's OK...

    I tried several times and I think this principle should work...

Add a Comment

For me (on my M1 Mac mini) the solution was to connect my Samsung T5 SSD via a USB-A-port and not via USB-C. After that the installation could be done without any problems.

  • This solved the issue for me too, thank you @linusK!

Add a Comment

i solved it first install big sur on external drive and then upgrade it to moterey. used t7 2tb.