Outgoing mail servers

I have five email accounts that use the same incoming and outgoing mail servers; they only differ by the username and password for authentication. When installing the 10.11 beta 1, the installer deleted all of these outgoing mail servers except one, but stripped out the username and password. I can edit that one to add the information for one email account so it will work. And I cannot add them back as the '+' and '-' in the edit server windows are dimmed. Anyone else have this issue? Any fixes found?


Same here. I can add (+ and -) accounts but I'm not able to add an alias under iCloud as I was used to do.

Same problem for me as well. This started with El Cap R1 and didn't fix itself with R2 release yesterday. I can receive icloud emails but the outgoing server is blank and can't be selected. The + - edits in the SMTP lists are greyed out so I can't add it back.

I also lost passwords for Gmail and other IMAP accounts but they worked fine on reentry. Exchange account not affected at all.

Stuck with no outgoing icloud mail at the moment.

I ran into this problem and found a workaround: if you add a completely new account to Mail, as part of the setup process it asks you to configure an Outgoing Mail Server for the new account. If you go through this process it will take the information you provide in this setup and add it to the list of configured SMTP Servers. So, I basically went through the process of adding a dummy account and then when I got to the end, I seemed to run up against another bug that prevented me from completing configuration of the new account. But when I cancelled and opened up the previous account, the newly added SMTP Server was available from the list of available servers.

I now have a solution thanks to this old thread.


The option to edit your incoming mail server is grayed out because of the new option in Yosemite to "Automatically detect and maintain account settings." Disable that option in the advanced settings of your account in Mail, click back to General settings, and select save settings on the popup that appears. Then you will be able to edit your incoming mail server.

When I deselected the option and looked at the advanced settings the icloud outgoing mailserver reappeared and I was able to select it. Now my old dot mac address is working again after a week of head scratching.