iOS15 BETA + SKProductsRequest Empty/Fail

I started receiving a few emails from users having iOS15 BETA Version 6 installed, noting that my in-app purchases were 'not showing up'.

All of my code works well on iOS14.7 and below and has been working well for the past year.

I'm currently using StoreKit SKProductsRequest to receive my in-app purchases and if this method fails, the in-app purchases do not 'show up' so I believe this is root cause of the issue. I need to implement better error handling to know if 1) it's returning an empty array of products of 2) failing to return any products.

But in either case, is anyone else experiencing this issue? Are there any new requirements for iOS15 for SKProductsRequest or has the schema changed?

I will be implementing better error handling and these few users have agreed to report back with the error message details. I will update this message when I receive this feedback but in the meantime, does anyone have an idea of what this might be?

Question to the community / Apple: Will StoreKit 1 code still work with iOS15? I assume the answer is 'yes' but I'm just very confused as to why my current code is currently broken on iOS15 Beta 6, but has been working on iOS14.7 and below...

Any help would be greatly appreciated. Thank you.

Post not yet marked as solved Up vote post of ibdakine Down vote post of ibdakine
1.7k views
  • Update: iOS15 Beta Version 6 + TestFlight Download --> My in-app purchases are behaving properly. All works well.

    iOS15 Beta Version 6 + App Store Download --> My in-app purchases (specifically the SKProductsRequest) is failing.

  • Update #2: iOS15 Beta Version 6 + App Store Download --> Consumable IAP work, however auto-renewing subscriptions do not.

    This is incredible difficult to test, as it requires me to release an update on to the App Store, handle the error correctly with an error message to even determine what the error is... any help would be greatly appreciated. Thank you.

Add a Comment

Answers

Hi, could you file a feedback report and follow up to this post with your feedback ID? Please include a link to your app or your app's bundle ID, and a sysdiagnose after reproducing this issue with your app if possible.

Hi, am facing the same issue in iOS 15 RC, Xcode 13 RC in all of my apps, in iOS 14 it works fine. The SKProductRequest, no methods get called, neither fail nor success. Also, we observed that it start happening when the app status in Testflight changes to RENEW.

Once it happen in sandbox then it also start happening in our/third party live apps, i.e one that are downloaded from Appstore.

What we checked

  1. All Agreement Accepted.
  2. Banking details proper
  3. Certificate and profiles proper
  4. In-app and bundle id proper
  5. Checked with multiple sandbox and live accounts.

Strange thing is it works until the testflight app status changes to "RENEW".

I am seeing the same issue on iPadOS 15.

Fails to return products or restore purchases. This seems to be specific to auto-renewing subscriptions.

Rebooting the iPad allows it to work the first time, then fails with no results after that.

No issues with code on iOS 14.

FB9650399.

  • Erase All Content and Settings briefly resolved the issue, but soon returned to only working after reboot.

Add a Comment

Seems like it’s a weird issue related to:

  1. This sandbox account
  2. This device
  3. iOS 15

This seems to have resolved it currently:

  • Settings | App Store | Sandbox Account | Sign Out
  • Reboot
  • Run app and try to make/restore a purchase
  • Sign in with a different sandbox account

The original sandbox account works fine on iOS 14, and still causes an issue if I log back in with it.

  • I have the same experience. It works 1 time after a sign out and reboot and then stops working.

Add a Comment

We're still having these issues. Has anyone found a solution, or are we waiting on a fix from Apple? We've certainly done our part with bug reports and sysdiagnoses, but haven't had any response to our report.

Same issue! Using an old sandbox account. All of a sudden iaps are broken. And I can't download apps, or get an iaps when the device is in this state. I thought production was down..

Background Task 14 ("SKProductsRequest"), was created over 30 seconds ago. In applications running in the background, this creates a risk of termination. Remember to call UIApplication.endBackgroundTask(_:) for your task in a timely manner to avoid this.

Our feedback report FB9692102 changed to indicate:

Recent Similar Reports:Less than 10

Resolution:Potential fix identified - For a future OS update

After updating to iOS 15.0.2 (production version), I calmly tested my applications if I put them from the Xcode or from the TestFlight. But at some point, uploading information about my iAPs stopped working. As wrote above, restarting the device helps, but after you log into the test version of the application and download the information about iAP for the first time, then the next times downloading information about iAP stops working. It is also impossible to make any purchases. And as a result, the production versions of Youtube and Youtube Music stop working (very interesting). Only restarting the device helps :(

  • UPD: information about purchases began to come by itself again. I do not know what it was, for two days I suffered with it

Add a Comment

Hi my app is currently in review. It was rejected, because the IAP purchase failed on an iPad iOS 15+. I've tested with iPhone and an iPad on iOS 14 and everything works as it should. I also have another app in the AppStore that was working correctly with the same method.

One thing I should note is that somehow I had to change my product identifiers to fetch the SKProducts from AppStoreConnect. Up until now I used "com...buyMeCoffee" as an identifier. For some reason this ended up having an empty array of SKProducts, so now I use "buyMeCoffee" and this successfully got me an array of my IAP products. I don't know if this has anything to do with this particular problem.

Anyway if someone has a fix, or a tip where to start looking I'd appreciate it!

  • Sorry couldn't see where to edit my original post, but the product identifier was my own fault. So ignore that. I'm submitting my app today again, hopefully everything will be good! Cheers.

Add a Comment

For me this issue is resolved since iPadOS 15.1.

  • my problem has also been solved with ios 15.1

Add a Comment