Cloudkit - Service Unavailable (6/2022) Request failed with http status code 503

I'm facing issue from few days with CloudKit. When I try to fetch any record from Cloudkit it gives me following error:

<CKError 0x6000006ec420: "Service Unavailable" (6/2022); "Request failed with http status code 503"; Retry after 30.0 seconds>

Also, when I try to query records from Cloudkit dashboard I receive "Internal error". I have not done any write operations.

Please help if anyone has solved this type of error.

  • I am having the same issues for a small percentage of my users. I have submitted a bug report to Apple but have not heard back yet. Even after waiting for days, the 503 error persists for some of my users.

  • @bchandresh, I am unable to replicate the 503 errors on my device but some of my users are experiencing the issue. It looks like you are seeing the issue on your device, so can you please do the following: Download the CloudKit profile on your device and then follow the instructions. Submit a bug report with that log file and it will help Apple determine what the issue is. I would do this myself, but I cannot replicate the issue on my device.

  • I've also been getting these errors with a small percentage of users. It started about two weeks ago. I can't reproduce the error locally.


maybe your app has enough users hitting CloudKit at the same time that its tripping over the rate limit?

  • I have no users yet. It has only one user that's me in the development environment.

Add a Comment

We're also seeing this issue with a lot of our users. Is there anything we can do on our end?

At last my problem got resolved. I have figured out that my app identifier has 2 iCloud containers attached with. I removed the iCloud container which was not in use.

Steps to edit iCloud container.

  1. Go to your developer account
  2. Certificates, IDs & Profiles
  3. Identifiers
  4. Select your app's identifier
  5. iCloud > Edit Container
  6. Choose the correct iCloud container

This did solve my problem. Hope it works for you too.

  • It's not working. Ignore above answer.

Add a Comment

Same problem in my app: <CKError 0x6000...: "Service Unavailable" (6/2022); "Request failed with http status code 503"; Retry after 30.0 seconds>

In my case the Apple's Feedback assistant is avoiding the problem and does not get involved in finding the solution

The problem was from apple side. They believe that the problem is now solved.

Thank Apple team. My problem gets resolved. I don't see these type of errors now.