After upgrading to Xcode 13.2.1, debugging with a lower version of the iOS device still crashes at launching

dyld: Symbol not found: ___chkstk_darwin

  Referenced from: /private/var/containers/Bundle/Application/2D78E028-8BEF-435C-9194-89A1D4C6F1AB/Client.app/Frameworks/libswift_Concurrency.dylib (which was built for iOS 13.0)

  Expected in: /usr/lib/libSystem.B.dylib

 in /private/var/containers/Bundle/Application/2D78E028-8BEF-435C-9194-89A1D4C6F1AB/Client.app/Frameworks/libswift_Concurrency.dylib
  • What is your build target?

  • Build target: iOS10.0 Debugging device: iOS12.5.5

  • Crashes even with iOS 14.5 simulator

Add a Comment

Replies

xcode 13.2.1 still crash when launch to device (iOS 12.0, iPhone 5S) Library not loaded: /usr/lib/swift/libswiftCore.dylib

I have same issue with Xcode 13.2 and 13.2.1, but version 13.1 of Xcode resolve that problem. You can download it here https://developer.apple.com/download/all/?q=Xcode%2013

Same here

I have the same issue, also on Xcode 13.2.1. Our app compiles for iOS 12 and runs in simulator, but crashes on a real device with the same error that OP posted.

Downgrade to Xcode 13.1 for now as this seems to be the only solution till they release another fix.

add libswift_Concurrency.tbd in the "Link Binary with Libraries" build phase (and make it optional).

libswift_Concurrency.tbd not work with Xcode 13.2.1

Same, I got plenty of crashes in my app ( ScannerLens ). I have tried to make libswift_Concurrency.tbd optional but it doesn't work! I do not use any concurrency api at all! Finally I remove the libswift_Concurrency.tbd file after build finished, and it works. you can try like:

Edit Scheme... -> Build -> Post-actions -> Click '+' to add New Run Script

rm "${BUILT_PRODUCTS_DIR}/${FRAMEWORKS_FOLDER_PATH}/libswift_Concurrency.dylib" || echo "libswift_Concurrency.dylib not exists"

And then wait a new xcode version to fix this issue.

  • thank you this solved the problem for my Scala 40, Ramino, Pinnacola, Machiavelli and Burraco Italiano apps, many customers were complaining about this problem causing crashes on iOS 12

  • I was wrong, it works on my local devices during development, but then, when going to review, the binary is refused due to some error with frameworks

  • after Edit Scheme... -> Build ->, I didn't get any Post-actions

Add a Comment

According to recent posts in https://forums.swift.org/t/swift-concurrency-back-deploy-issue/53917/27 seems like a fix is in Xcode 13.3 (currently beta)?

Xcode 13.3 beta 1 has a fix for the crash.