Keychain Access

When trying to build an AR app to my Iphone 11 with Xcode (13.2.1) using Mac OS 12.1 the build fails. Codesign wants me to use the Apple Development keychain. No matter which password I use it fails.

Post not yet marked as solved Up vote post of margotedxsi Down vote post of margotedxsi
3k views

Replies

Hi,

I was experiencing this exact issue... I tried every password I could think of but everything failed. Then by mistake, I pressed the OK-button without entering a password. And it worked! I can also unlock the custom keychain for "Apple development" in the Keychain Access app by just leaving the password empty.

Hi @lars.lindback, I'm facing the same issue with the Codesign fail scenario as @margotedxsi mentioned, there's no OK button and can't leave it blank either...

Anyone else has encountered this issue? I can't proceed to run the app and test codes further at this stage to verify the developed features.. Kindly advise what could have gone wrong. Thanks.

After multiple trials and errors, here are the steps that I finally got it through in case anyone encounter the similar issue :

  1. OpenKeychain Access, in the search bar, type ‘apple’, I notice somehow I have 2 Apple Development: xxxxx private key [ xxxx => your name ]. So, I delete both since I don’t know which to retain, their content both look identical after inspect.

  2. Back to Xcode -> Preferences -> Accounts -> Add back my AppleID

  3. Run the app, on the code sign prompt, enter the computer password, then click Always Allow directly

Got the same, happens once a year, long enough for me to forget how to fix this problem with development certificates. Opened the keychain as kindly posted by CloverSly, found one developer certificate that has expired, deleted, and my app works now (I think XCode created a new one that expires next year), so I can expect to be back here next year.

Maybe one day/year/decade Apple will come up with non expiring developer certificates.