Controller not working in macOS 12.3

I tried to connect my xbox controller to my MacBook, even though the controller is registered in bluetooth setting, but it doesn't function at all. Have anyone met the same problem and if there's a fix for this problem

Answered by Frameworks Engineer in 733299022


We appreciate your feedback in the Developer Forums. We believe this issue is already resolved in macOS 12.3.1. If you are still seeing this issue, please submit a feedback report to ensure the issue can be investigated by the relevant engineering teams. You can do so from the Feedback Assistant app or Feedback Assistant website.

Im having this issue as well. I deleted the controller from the bluetooth devices list. Re synced it and the problem still persists.

Hi Wisky_pro. Which apps or games are you trying to use your Xbox controller in? Would you happen to know what kind of Xbox controller you have?

Can attest to this issue, a DualSense Controller paired over bluetooth does nothing after updating to macOS 12.3. Tested with multiple Apple Arcade games (e.g. Tetris Beat that supports controllers that used to work perfectly before 12.3) and multiple other non-Apple Arcade games all of which supported controllers before 12.3.

Thanks the_lucifer. I saw your feedback report.

Xcode 13.3 Yes sir. I have a Steel Series on my macOS 12.3 and an Xbox Controller on my iPhone 15.4. With the iPhone 15.4 the Virtual Controller Comes up, and works, then when connecting the Xbox the VC goes away and the Xbox Controller works. With my MBP 16 M1Pro macOS 12.3, the observation methods get registered, but NEVER get called... I cannot trigger the "didConnects" Whether turning on before launch after launch etc Been looking for some NEW PLIST entry can't find anything...glad I am not the only, cause now I can go to something else...thanks ¯_(ツ)_/¯

I have a same issue. Is there any solution?

I am experiencing the same issue after I updated my MacBook pro to 12.3 two days ago. Tried numerous troubleshooting attempts. I have the normal white wireless Xbox controller I bought from GameStop.

Does anyone have a fix for this?

I have same issue....

How to slove this problem? I have same issue.

Restarting the computer can fix the problem, if once doesn't work, then twice.

I'm not entirely sure why this happens, it happens intermittently for me. The last attempt I took was Delete the controller, Turn off Bluetooth, Restart, Reconnect Controller- but while I was reconnecting there was a phantom controller that popped up that showed the original controller connected, but I could not disconnect it through the Mac, I turned the controller off and the phantom controller popped back down to the unknown devices and upon entering bluetooth mode on my ps4 controller the phantom controller was identified as a ps4 controller and I was able to connect and use the controller again to play games. I hope this helps!

I still have a weird issue, but like I said on my iPhone, my Xbox controller will connect, and then make the Virtual Controller disappear indicating that the Controller is connected (at least). But nothing functions from the Xbox controller. Then turn off controller and Virtual Controller comes back on... (the controller is there in the debug info, Mac too if I am not mistaken).

Xbox One controller via USB worked before macOS 12.3.

Now, doesn't get detected at all.

Same problems here. My controller is working in some games, but not everywhere:

  • macOS: 12.3 (21E230)
  • Xbox Wireless Controller:
  • Manufacture ID: 0x045E
  • Product ID: 0x02FD
  • Firmware: 9.0.3
  • Additional type: Gamepad

Working in apps:

  • Steam
  • Pac-Man Party
  • The Pathless

NOT working in apps:

  • Sonic racing
  • Asphalt 8+
  • Agent Intercept

Also experiencing the same issue. My Nimbus + Controller won't work with Apple Arcade after updating to Monterey 12.3. I'm able to connect via bluetooth, but none of the buttons work. I'm sure there are a lot of Mac Gamers with the same issue and hopefully Apple fixes this soon.

Hi all, thanks for your feedback and patience.

Engineering is aware of the issue and is working toward a resolution

My solutions, found partly thru MacRumors, was to Safe Boot, an re-pair. Then boot normally. Viola

iPhone all I had to do was shutdown the iPhone and reboot the iPhone, launch app worked.


Tested this on 12.4, still having troubles.

Looks like two games I tested have broken controller support. Both of them are Unity games using the InControl framework. I tried three controllers with each: An Xbox Series X controller, a DualShock 4 controller, and a Stadia Pro controller connected via USB, which appears as a generic controller with vaguely Xinput like features.

Games tested: The World Next Door, Turnip Boy Commits Tax Evasion.

Unrelated, Barony for macOS seems to require me to double-click for it to register a single left click now. Cool, games get progressively more broken.

Just adding my experience to the list in the hopes this gets addressed. I have tried three different bluetooth controllers (XBOX One, PS5 DualSense, Nintendo Switch Pro Controller) and the issue is the same across all 3. Bluetooth has no problem connecting the controllers to my M1 MacBook Pro, pressing the Home buttons on each controller brings up a game selection bar, and I can use the controller to select games. However, regardless of which game I select, once I am in-game, no controller input works except the Home button to bring the game selection menu back up. No issues prior to the Monterey 12.3 Update.

Hoping this gets addressed soon!

I'm also having this problem. My Nintendo Switch Controller Pro connects over bluetooth, but the buttons don't work in any software.

I am with SP5246-202010 For Nintendo Switch Controller Pro on Monterey 12.4

I tried to connect it through normal boot and safe boot. Both result in connecting..., and then connection rejected.

I also tried to pair some other devices in both boots, it works fine.

So, that means I cant even get my controller to pair up with my Macbook Pro, unlike some of you mentioned above that you could use the controller in a certain game.

I tried to livestream the log through console. I am not a pro in IT but hope it helps. There are two findings. #1 When plugged in via USB cable and press the pairing button on my controller, console shows that the USB port read the signal and immediately disconnect shortly afterwards. #2 When pairing via bluetooth, message "configuring controller, will try again later" will nonstop pop up until Bluetooth stop trying to pair up with the controller.

I didnt submit an official ticket to Apple. If any of your delegate would like to help out please reply to this message AND email me, it will be the same address as my apple ID.


I'm having same problem, noticed the ps4 controller is working fine with it but ps5 controller is not. The symbol/icon when i connect my ps5 controller vs my ps4 controller via bluetooth is different. The ps4 controller shows an ps4 controller icon and allows me to connect normally. The ps5 controller shows a normal bluetooth symbol (same as my iphone). When connected a monitor will show a monitor icon next to it, a mouse will have a mouse icon, a speaker shows a speaker etc... Somehow need to change how the mac bluetooth recognizes the controller.

Atari classic controller also doesn't work anymore. MacOS Monterey 12.4, M1

Just adding that I'm having the same issue. I've tried Xbox One, PS4, and a generic controller that I used to use frequently and none have worked. I've tried all of them corded and Bluetooth with no luck. The game I've been trying to get it to work with is Final Fantasy XIV by Square Enix. I've been seeing advertisements for another new OS update, any word if we'll receive a fix before or even with the new update?

Same issue. I have not even been able to use a WIRED xbox 360 controller OR any bluetooth controllers with any of my steam games, as well as any of my other games including emulators.

Updating to Monterey has completely ended all gaming on my computer. Thanks a LOT apple. I will never buy apple again.

Controller not working in macOS 12.3