Xcode 14 resources bundle "CODE_SIGNING_ALLOWED" being set to YES

When archiving the app with Xcode 14 beta, we got some errors regarding resources bundle code signing.

xxxResources does not support provisioning profiles. xxxResources does not support provisioning profiles, but provisioning profile <...> has been manually specified. Set the provisioning profile value to "Automatic" in the build settings editor...

It turns out that in Xcode 14 beta, CODE_SIGNING_ALLOWED of resource bundle is being set to YES by default while it's NO in Xcode 13.x.

Is this an expected change or a bug introduced by Xcode 14 beta?

Post not yet marked as solved Up vote post of ntduyet Down vote post of ntduyet


Ping. Is anyone else also facing this issue?

I am also having trouble building projects in Xcode 14 which build correctly in Xcode 13. The same error everytime:
Signing for X requires a development team.
where X is a resource bundle target of the project.

  • A workaround could be to explicitly specify "CODE_SIGNING_ALLOWED": "NO" for resource bundle targets' build settings.

Add a Comment

A workaround could be to explicitly specify "CODE_SIGNING_ALLOWED": "NO" for resource bundle targets' build settings. 

  • I don't see an option in the app Build Settings for CODE_SIGNING_ALLOWED. Where is that located?

Add a Comment

We are facing the same issue. Where do we set CODE_SIGNING_ALLOWED for packages and not the whole app?

Can anyone explain what is happening? Why is Xcode giving this error in the first place, and why is CODE_SIGNING_ALLOWED a fix for it?

I mean, if the original error is not a mistake, then it sounds like a hack, and there should be a better solution

I also faced the same problem. Does anyone have Apple's documentation talking about this? I appreciate your support