missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

I have this problem: xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

Could someone help me? Two days ago I installed the last software update to MacOS: 12.5 and I have installed Xcode 13.4.1 for programming. Could this be the problem? Thanks for the support.

Post not yet marked as solved Up vote post of Nanah148 Down vote post of Nanah148



Please run following command in Terminal and then try.

xcode-select --install

  • thank you for your help

    I found the solution by doing a --reset there was certainly a conflict between the old version and the update in the path

Add a Comment


I tried running the following command in Terminal: and it prompted a window that says:

"The "xcode-select" command requires the command line developer tools. Would you like to install the tools now?"

and when I click "install"

The message I get after it searches for the software is:

"Can’t install the software because it is not currently available from the Software Update server."

Can someone help me?

I installed the public beta for Ventura today and now my computer wont allow me to run git commands.

Thanks for the support.

  • try:

    sudo mkdir -p /Library/Developer/CommandLineToolssudo touch /Library/Developer/CommandLineTools/.beta

    and then:

    sudo xcode-select --install

Add a Comment

I installed the public beta for Ventura today and now my computer wont allow me to run git commands.

If you’re running a beta release of a major new version of macOS you need to install the corresponding beta release of the tools. For macOS 13.0b4, that means either Xcode 14.0b4 or its corresponding command-line tools package. You can get these from the Developer > Downloads page. Xcode is under the Applications tab and the command-line tools package is under More.

Share and Enjoy

Quinn “The Eskimo!” @ Developer Technical Support @ Apple
let myEmail = "eskimo" + "1" + "@" + "apple.com"

  • thanks you, I had to restart my computer after installing XCcode Beta on my machine for the error to go away!

Add a Comment

Ideally the solution will be that apple cleans up their act and an OS upgrade really performs the upgrade of the system with all supported programs and operations intact.

This extra step, while easy, is just more inconvenience that takes away from the "it just works" mindset that apple has so painstakingly created and vigorously defended.