No suitable application records were found. Verify your bundle Identifier ' ' os correct.

So this is very frustrating. My bundle ID is the same in the itunes connect store as it is in xcode. However, when I try and validate my archive for submission I am left with this prompt. My only thought is I had someone code this for me and I added a splash screen as well as changing the app name. I thought I made all the right corrections. Any ideas guys?


I have the same issue.

I am trying to update a build, into iTunes Connect. I have also tried setting it as a new version as well. But nothing is working.

The warning asks me to confirm if the bundle id is correct, it is.

I had uploaded a build ealier today, succesfully. Now tho, a few hours later, I can not.

Very frustrated.

Hi i need help with this upload to mac store

Mac OS sierra

using xcode 8.2.1

Application loader 3.0 and later 3.6 same error

I got the same error as well. "No suitable application record found. Verify your bundle identifier ... is correct." Puzzling!

I got the same error as well. Any ideas guys?

i'm fetching the same error

I had been experiencing the exact same issue. I was attempting to upload a build for a project. I had uploaded many builds in the past over the last couple of years with no issue. I had verified that the bundle ids matched and they did. Nothing that I tried was working until I looked at user roles of the user I was using to upload the build to itunes connect.

There is an "Apps" field in the "User and Roles" page in iTunes connect. The apps field had the corrrect app selected for my user so things should have been working. I removed the app from the "Apps" field so that my user would have access to all apps managed under the account. After making the change, things worked for me!!! Looks like for some reason XCode could not find the application record because the user roles configured in iTunes connect.
I'm sure this won't solve the issue for everyone but it's worth looking into if you're running into the error mentioned above and have verified that your ids match.

Post not yet marked as solved Up vote reply of MI2 Down vote reply of MI2


I have been experiencing this same issue since this morning. The "Apps" fields is set to All Apps and I am not able to change it.

Someone else also having this issue?

For anyone having the same issue, give MI2's solution a try. It works for me.

It turns out that you have to go to "Users and Roles" page using admin account.

Remove all apps and it becomes "All apps"

Dont trust what you see on that page if you are not an adnin, because it will just show "All apps" but infact it's not "App apps" on admin account's view

That really worked.
I think Apple screwed up users and accounts when they started to move new roles settings.

I also face same issue. After the investigation I found the link As per this document 'If Xcode doesn’t find an App Store Connect record for your app, the validation fails with an App Store Connection Operation Error. In App Store Connect, Add an app to your account and ensure that the bundle ID matches the bundle ID in your Xcode project.'.

Then I check the role assigned with my account and It was only 'Developer'. So that I was not able to create or see my app under 'App Store Connect -> My Apps'. With 'Marketing' role I start seen option for creating new app. Also with new user role XCode pass app store build validation.

I've sorted mine - turns out that the case of the Bundle ID in Xcode and what it was expecting on App Store connect were different. Changed it in Xcode and my app validated. :-)

This guy's video solved this problem immediately! It's less than five minutes and well worth the watch:

The trick was to add a capability; I added In-App Purchases and it automatically created my bundle ID (which was immediately viewable on App Store Connect).

My user is in the App Manager group, and since the app is no longer in the App Store Connect (even if I wanted to add directly there, it doesn't fetch the bundle ID when I do "New App") it isn't assigned to me. And I get this exact problem, when I try to validate the build in Xcode.

I've verified if the bundle identifier exists in my account, and it does, so I don't really understand what could be the program.

What do you think it is?
I had this issue today, and in my case, it was a stupid user error.

I was setting up a new product on a developer account other than my own. Bundle ID and everything was configured correctly, and I confirmed that the identifiers were created in the correct place. However, I forgot to create an App.

I was in the habit of testing this out on my own account, and simply forgot this critical step on the new account. I'm sure it's not what all you lot are doing, but it's a reminder that you should at least check the status of the App in Apple Connect. If it does exist, make sure it's available. I.e, not removed.