External hard drive not showing up

I have a 1TB external hard drive made by Seagate which I use for Time Machine backups. It is not showing up as mounted, and doesn't show up in a graphical interface anywhere in the system at all. On my desktop, I do not see my drive connected, and it doesn't show up in a Finder window under the devices sidebar tab. Doesn't show up in Disk Utility either (actually Disk Utility won't even load/launch at all while my drive is connected). I ran "diskutil list" in Terminal, and my drive did show up there. I also tried "diskutil mount /dev/disk2s2" in Terminal to try to mount my hard drive from the command line, but Terminal would freeze up almost immediately. I also plugged my drive into a Chromebook and the Chromebook could read every file on my drive. I have already checked the cable and the connectors on each end, and that's not the problem. I can safely assume that this is a problem with my personal MacBook Pro or with my drive only. Re formatting my hard drive is an option I would like to stay away from, although it is somewhat feasible. I've already tried resetting the SMC and the PRAM, along with re-installing a new copy of macOS via Recovery boot mode, and none of that worked. I have tried almost everything, and it looks like I'm gonna have to re-format my drive. But before I do that, does anyone have any other suggestions I could try?

Idealy, I'm looking for a setting/file to change via Finder or Terminal to force my MacBook to be able to read/write to my drive.


Here a few screenshots. These were all taken with my hard drive plugged into my computer. Sorry if they are ginormous in size. I have blurred out some sensitive info.

This has been going on for almost 3 weeks now. Any ideas for how I can solve this problem/get my drive to show up??

Thanks in advance for anything!!


~ Capt Inc - Feb 28 2017

13" MacBook Pro with Retina display (Early 2015 model) running macOS Sierra 10.12.4 beta 16E175b

Answers

Seen the MTL links below?

Yes, but none of them are like my drive. My drive doesn't show up at all, except when "diskutil list" is run in terminal. Only "diskutil list" works, not "diskutil mount" or "diskutil unmount" I believe I have a special case problem, and I'm wondering if anyone has any suggestions. Thanks!!

Sorry, I thought the kinks about seagate drives were like your seagate drive.

No problem. The thing I am confused about is my drive was working just fine 3 weeks ago back in the 10.12.3 beta versions or so. I can't recall exactly when my drive stopped showing up, but I would guess it was right after I updated to the 10.12.4 betas. Idk, maybe there is something wrong with my specific Seagate drive. Can you tell me something else? How likely is it for a drive to stop mounting on macOS only if you just unplug the cord without ejecting it first? Remember, it shows up on Chromebooks, which can natively read the Mac OS Extended format, unlike Windows. Thanks!!

>How likely is it for a drive to stop mounting on macOS only if you just unplug the cord without ejecting it first? Remember, it shows up on Chromebooks, which can natively read the Mac OS Extended format, unlike Windows.


That's a loaded question in this context. All bets are off when chasing 'likely' scenarios when a beta is involved. What 'shows up' in other/non-macOS beta scenarios has no bearing in your beta example. What you're really asking is "how likely is it that my problem is related to the beta I'm using?"

Please see my reply dated "Mar 21, 2017 12:05 AM" on this thread where I suggest a work around.

I admire your afinity for Logical Syntax, but he needs help making his external drive compatible with an upgraded software, not Formal Logic...

My 2TB external HD was recognised by Disk Utility (but not finder), and Verify Disk was showing no problems. But, it still was unmounted NTFS-3G. So I tried 3rd party software to help my mac read the NTFS-3G file system. I've installed Mounty, Fuse with NTFS-3G, and Tuxera NTFS for Mac, all at the same time, then restarted my mac. Now, my Seagte NTFS-3G is recognized by finder. One of those programs worked. I am able to backup my files to a diffferent HD. I hope this helps. Good luck.

My external drive stopped showing up. I tried everything suggested by different users which included:
  1. Use disk utility and try running First Aid, Mount, Eject.

  2. User terminal and run command diskutil list, info, eject, mount

  3. Restart mac

  4. Try different USB cable

  5. Try attaching the external drive to a different Mac

None of the above steps worked. I decided to use Windows and it rescued me in this situation where Mac was a total failure. I attached the external drive to only Windows laptop I had and it offered me to scan/fix errors on the drive. It worked like a charm. After fixing, it was successfully recognized by my MacBook and Mac Mini.