Warning: unable to build chain to self-signed root for signer "Mac Developer: Dylan M (*******)"

I keep getting this Warning each time I test:


Warning: unable to build chain to self-signed root for signer "Mac Developer: Dylan M (*******)"


I have no Idea what it means and couldn't find any other case of it on the internet, could anyone help?

Post not yet marked as solved Up vote post of DylanM Down vote post of DylanM
47k views

Answers

I am experiencing this exact same issue in Xcode 9.0.1 (9A1004) on macOS 10.13 when trying to debug on device running iOS 11.0.3 iPad or iPhone.


I have set both devices to allow trust running apps from this identity in Settings > General > Device Management. I have tried manually deleting all certificates from my computer keychain, then restarting Xcode and redownloading the certs anew, but the problem persists.

I solved my problem by:

- Removing all account information from Xcode and quitting Xcode.

- Open Keychain Access and delete all my certificates, as well as all Apple root and intermediate certificates.

- Manually resintall all Apple root and intermediate certificates.

- Relaunch Xcode and open Preferences > Accounts. Sign in to dev account, and select Download Manual Profiles.

Please try after reseting your keychain access password.

That works thanks (Xcode 9.1). hope Apple will fix it in next release .. 🙂

Thanks for your sharing. Can you tell me how to delete and reinstall Apple root and intermediate certificates?

Delete certificates from the Keychain Access app. In Keychain Access, make sure you have the proper keychain selected on the left pane. Select Certificates in the Category listing (again on the left). Contextual menu click on each certificate and select Delete.


To install Apple Root and Intermediate certificates manually, download the appropriate certificate and double-click on it. It should open Keychain Access and install. These certificates are available at https://www.apple.com/certificateauthority/

That did not work for me.


This warning persists, but apparently the codesign is still accepted.


spctl -a -t exec -vv /path/to/MyApp.app

accepted

Likewise here, I've followed every suggestion in this thread and I still get the same original error.


Running the spctl command above indicates that the IPA is not signed correctly. (My problem is I need to modify the IPA after build and change some images, then re-sign it).


Any help would be appreciated.

Tried all suggestions in thread and still get the same error: Warning: unable to build chain to self-signed root for signer "Apple Development: ....


I have not been successful in getting any help from Apple.

Add a Comment

I may be late for this, but to solve this follow these steps...


xcode -> preferences -> accounts -> select the account -> manage certificate -> click on the + icon on the bottom left of the popup window -> ios development


you will see a new certificate created. Now you can run your app.

  • This worked for me (Xcode 13), thanks!

Add a Comment

There was no need for me to delete all my certs.

Identifying the bad certificate:


  1. From you Keychains select Login
  2. From Category select Certificates
  3. Find any Apple Certificate that has the blue +
  4. Double click on the certificate.
  5. Expand the Trust
  6. If it's messed up then the "When using this certificate" is set to "Always Trust" along with the blue +

Fixing the bad certificate:

  1. Just set it to "Use System Defaults" and close it.
  2. You'll get a pop up. Type in your password to update settings.
  3. Close KeyChain. Go back to your project, clean and run. Problem should have gone away.
  4. If that didn't work then go back to Keychain and just double check and see if there are any other Apple certificates that are set to Always Trust and repeat the process.
  • Thanks, just deleted all expired certificates and the error gone away for Xcode 13.0 beta (13A5154h).

Add a Comment
@honey9 Thanks worked for me in Xcode 14 Beta 2.
  • @honey9

    thank you! this worked for me. especially since i was code signing via the command line. step 4 in fixing the "bad" certificate is what got it working for me eventually. thank you so so much

Add a Comment
@honey9
I am really appricated for your brallient solution, this worked for me very well. Tks a lot.
If none of the above works, download the WWDR Intermediate Certificate and drag and drop into your 'System' keychain. Don't put it in 'login' - I tried that myself and it did nothing to help me. Try to avoid changing the trust settings of your certificates, Xcode gave me a warning when it saw I had modified my development certificate's trust settings.
  • thank you! it works

  • ^^ this worked for me too, but why this happened is not known to me yet.

  • Worked for me three

    On a .app file 10.15.7 Mac mini 2018

Add a Comment
Thanks  @FrostyBagg

This is the only thing that has worked for me in new Mac Mini