SMS Character Count Issues with Apostrophe

Having issues with an SMS Text dropping in character count when typing an apostrophe. SMS Text messages will start at 160, but with an apostrophe it drops to 70 as if there was a special character or emoji in the field. Is anyone else experiencing this issue? I've updated through each Beta release, factory reset my device, and deleted text threads- still drops to 70 with apostrophe.

Post marked as unsolved Up vote post of sa302605 Down vote post of sa302605
5.5k views

7 Replies

Hi,


I have been having issues with sending Text Messages ( SMS ) to some of our Customers at work. The reason that the Turning Off of Smart Punctuation seems to fix this problem is due to the the use of a U+2019 RIGHT SINGLE QUOTATION MARK. When pluralising any word or using the aopostrophe key it is now set as right single quotation as default. Long pressing that button will show all chars available, including the Single Quotation which is preferred.


The reason the character count reduces is because this Right Single Quote Mark, fits outside of the ASCii and so the max number of chars which can be sent in Unicode is 70 because each char takes up more 'space'.

I meant smart punctuation

Yes I too have just started having problems, I have done what the person suggested to remove auto punctuation which does sort it but I shouldn't have to do this. Hopefully Apple will sort an update out.

Disable "Smart Punctuation" in Keyboard Settings.

Disable "smart punctuation" in Keyboard Settings.

I am having this issue as well and have tried contacting apple support multiple times. They keep recommending backing up the phone and restoring it, but I don't believe this will do anything. They've also tried straight up replacing my phone instead of trying to find a solution. If you guys figure anything out, please post it here.

Yes, I’m having the same issue. I have not figured out a fix. Any luck on your end?