web inspector disconnecting

Safari 11.0.1/MacOS 10.13.1 is unable to maintain a web inspector connection with a web page on Safari iOS - iPhone 6, iOS 11.1.1. Almost immediate after the Web Inspector window opens, the connection is dropped and the window is basically dead.

Post not yet marked as solved Up vote post of Advent Media Down vote post of Advent Media
8.6k views

Answers

Same issue here (Safari 10.1 with IPHONE 6 iOS 10.3),


seams to occur when the phone is full battery charged but not sure... did you found a way to fix it ? 😟

The disconnection seems to occur when the battery of the Iphone is full. (So for the moment we turn the flash and the camera on to kill the battery while inspecting ...)


Nevertheless, when the battery isn't full the inspector disconnects every 5/15 minutes which is quite embarrassing.

I'll try running the battery down and give that a go.


I found another thread where they were saying safari 11.1+ was required, so upgraded to high sierra and the safari web technology preview. No joy.


In console I could see this error:



RWIServiceLockdownConnection: failed to read bytes from webinspectord, so disconnecting: Undefined error: 0

RWIServiceDeviceConnection: Closing connection (Direct)

****, you were right. if the battery isn't 100% then it can debug.


It must be the phone signalling to not supply usb power, and that stops the debug as well


Update:

Incidentally, there is an option in the develop menu.

Develop > Marks iPhone7 > 'connect via network'

That works and means the phone isn't charging at the same time.

I have the same problem on High Sierra (iMac)...


Safari hangs (and sometimes halts the whole system)


Seems to has begun with the latest 10.13.4

Same on my side, High Sierra on a Mac Pro (current model).

The console gets flooded with the following message:


RWIServiceLockdownConnection: failed to read bytes from webinspectord, so disconnecting: Undefined error: 0


This morning I had three disconnects of network services and was foreced to reboot. - I'd guess something is wrong here.

This helped me. Choosing Connect via network now no longer require the wired connection.

I still have this issue in safari 12.1.2 on Mojave. Using usb, wifi switching use network connection on or off. nothing helps. The debug windows opens for a second and then its gone, including hte connection (seeen by the menu entry of my iPhone dissappearing).

Trying to debug a cordova app, debug build, installed from xcode.


Sometimes, after ??? x trying it stays connected for a gracefull period of unknown duration, in which time I hope to get to see what I wanted.


Anyone any suggestions?

It still disconnects for me with the battery at 88% and selecting "Connect via Network" does not help. I'm using macOS Catalina.

Still happens and makes debugging anything in iOS Safari impossible. Can we please just deprecate Safari? It's clear there are no resources being pumped into it's development
This problem is blocking the development in my company. November 2020, it hasn't been solved yet.
iOS 14.2 MB Pro MacBook Pro (13-inch, 2019) - OSX Catalina 10.15.7, Safari Version 13.1.3 (15609.4.1)
still having this issue
This is still happening on MacOS 11.1 and iOS14. Sometimes it's stable and other times it drops on both wired and wireless connections. Its very frustrating.

@apple do you have a planned fix for this?
I still have this issue macOS 11 iOS 14
I have the same issue. macOS 11.2.1, iOS 14.4